summaryrefslogtreecommitdiff
path: root/peripheral/libupm/src/bacnetmstp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'peripheral/libupm/src/bacnetmstp/CMakeLists.txt')
-rw-r--r--peripheral/libupm/src/bacnetmstp/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/peripheral/libupm/src/bacnetmstp/CMakeLists.txt b/peripheral/libupm/src/bacnetmstp/CMakeLists.txt
new file mode 100644
index 0000000..8f23f7e
--- /dev/null
+++ b/peripheral/libupm/src/bacnetmstp/CMakeLists.txt
@@ -0,0 +1,24 @@
+set (libname "bacnetmstp")
+set (libdescription "upm driver module for BACnet MS/TP devices")
+set (module_src ${libname}.cxx device-client.c bacnetutil.cxx)
+set (module_hpp ${libname}.hpp bacnetutil.hpp)
+
+pkg_check_modules(BACNET libbacnet)
+if (BACNET_FOUND)
+ set (reqlibname "libbacnet")
+ include_directories(${BACNET_INCLUDE_DIRS})
+ upm_module_init()
+ add_dependencies(${libname} ${BACNET_LIBRARIES})
+ target_link_libraries(${libname} ${BACNET_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+ if (BUILDSWIG)
+ if (BUILDSWIGNODE)
+ swig_link_libraries (jsupm_${libname} ${BACNET_LIBRARIES})
+ endif()
+ if (BUILDSWIGPYTHON)
+ swig_link_libraries (pyupm_${libname} ${BACNET_LIBRARIES})
+ endif()
+ if (BUILDSWIGJAVA)
+ swig_link_libraries (javaupm_${libname} ${BACNET_LIBRARIES})
+ endif()
+ endif()
+endif ()