summaryrefslogtreecommitdiff
path: root/peripheral/libupm/src/tb7300/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'peripheral/libupm/src/tb7300/CMakeLists.txt')
-rw-r--r--peripheral/libupm/src/tb7300/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/peripheral/libupm/src/tb7300/CMakeLists.txt b/peripheral/libupm/src/tb7300/CMakeLists.txt
new file mode 100644
index 0000000..8564c80
--- /dev/null
+++ b/peripheral/libupm/src/tb7300/CMakeLists.txt
@@ -0,0 +1,28 @@
+set (libname "tb7300")
+set (libdescription "upm module for the TB7300 Fan Coil Thermostat")
+set (module_src ${libname}.cxx)
+set (module_hpp ${libname}.hpp)
+
+pkg_check_modules(BACNET libbacnet)
+if (BACNET_FOUND)
+ # upm-libbacnetmstp will bring in libbacnet, I hope
+ set (reqlibname "upm-bacnetmstp")
+ include_directories(${BACNET_INCLUDE_DIRS})
+ include_directories("../bacnetmstp")
+ upm_module_init()
+ target_link_libraries(${libname} bacnetmstp)
+ if (BUILDSWIG)
+ if (BUILDSWIGNODE)
+ set_target_properties(${SWIG_MODULE_jsupm_${libname}_REAL_NAME} PROPERTIES SKIP_BUILD_RPATH TRUE)
+ swig_link_libraries (jsupm_${libname} bacnetmstp)
+ endif()
+ if (BUILDSWIGPYTHON)
+ set_target_properties(${SWIG_MODULE_pyupm_${libname}_REAL_NAME} PROPERTIES SKIP_BUILD_RPATH TRUE)
+ swig_link_libraries (pyupm_${libname} bacnetmstp)
+ endif()
+ if (BUILDSWIGJAVA)
+ set_target_properties(${SWIG_MODULE_javaupm_${libname}_REAL_NAME} PROPERTIES SKIP_BUILD_RPATH TRUE)
+ swig_link_libraries (javaupm_${libname} bacnetmstp)
+ endif()
+ endif()
+endif ()