summaryrefslogtreecommitdiff
path: root/native/gl_finish/Android.mk
diff options
context:
space:
mode:
Diffstat (limited to 'native/gl_finish/Android.mk')
-rw-r--r--native/gl_finish/Android.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/native/gl_finish/Android.mk b/native/gl_finish/Android.mk
new file mode 100644
index 0000000..820f3ef
--- /dev/null
+++ b/native/gl_finish/Android.mk
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2010 0xlab - http://0xlab.org/
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+LOCAL_SRC_FILES:= \
+ gl_finish.cpp
+
+LOCAL_SHARED_LIBRARIES := \
+ libcutils \
+ libEGL \
+ libGLESv1_CM \
+ libui
+
+LOCAL_MODULE:= gl_finish_test
+LOCAL_MODULE_TAGS := optional
+
+LOCAL_CFLAGS := -DGL_GLEXT_PROTOTYPES
+
+include $(BUILD_EXECUTABLE)