summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandroid-build-team Robot <android-build-team-robot@google.com>2020-04-28 20:23:46 +0000
committerandroid-build-team Robot <android-build-team-robot@google.com>2020-04-28 20:23:46 +0000
commit134f0afe8a315e0c0cbfad44c13ab5f2ef00b4ce (patch)
treea78de485f00ce028f95887a8d7f6190c84b6111a
parent15d65ede5806793f4ebdf8c1d998f10a410095eb (diff)
parent1938ad4fc2cba17bedfdb7f55760cd8132b27de3 (diff)
downloadCalendar-android10-mainline-tzdata-release.tar.gz
Change-Id: I2b6ceb1dfb1f22f9d823617590d4d16100393261
-rw-r--r--Android.mk10
-rw-r--r--AndroidManifest.xml2
-rw-r--r--proguard.flags4
-rw-r--r--res/color/done_text_color.xml21
-rw-r--r--res/color/done_text_color_dark.xml21
-rw-r--r--res/values/colors.xml5
-rw-r--r--res/values/strings.xml2
-rw-r--r--src/com/android/calendar/widget/CalendarAppWidgetProvider.java4
-rw-r--r--tests/AndroidTest.xml30
9 files changed, 10 insertions, 89 deletions
diff --git a/Android.mk b/Android.mk
index 5cfdc85f..4b5744a7 100644
--- a/Android.mk
+++ b/Android.mk
@@ -4,8 +4,9 @@ include $(CLEAR_VARS)
# Include res dir from chips
chips_dir := ../../../frameworks/opt/chips/res
color_picker_dir := ../../../frameworks/opt/colorpicker/res
+datetimepicker_dir := ../../../frameworks/opt/datetimepicker/res
timezonepicker_dir := ../../../frameworks/opt/timezonepicker/res
-res_dirs := $(chips_dir) $(color_picker_dir) $(timezonepicker_dir) res
+res_dirs := $(chips_dir) $(color_picker_dir) $(datetimepicker_dir) $(timezonepicker_dir) res
src_dirs := src
LOCAL_JACK_COVERAGE_INCLUDE_FILTER := com.android.calendar.*
@@ -25,6 +26,7 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
android-common \
libchips \
colorpicker \
+ android-opt-datetimepicker \
android-opt-timezonepicker \
androidx.legacy_legacy-support-v4 \
calendar-common
@@ -35,17 +37,17 @@ LOCAL_RESOURCE_DIR := $(addprefix $(LOCAL_PATH)/, $(res_dirs))
LOCAL_PACKAGE_NAME := Calendar
-LOCAL_PROGUARD_FLAG_FILES := proguard.flags
+LOCAL_PROGUARD_FLAG_FILES := proguard.flags \
+ ../../../frameworks/opt/datetimepicker/proguard.flags
LOCAL_PRODUCT_MODULE := true
LOCAL_AAPT_FLAGS := --auto-add-overlay
LOCAL_AAPT_FLAGS += --extra-packages com.android.ex.chips
LOCAL_AAPT_FLAGS += --extra-packages com.android.colorpicker
+LOCAL_AAPT_FLAGS += --extra-packages com.android.datetimepicker
LOCAL_AAPT_FLAGS += --extra-packages com.android.timezonepicker
-LOCAL_AAPT_FLAGS += --legacy
-
include $(BUILD_PACKAGE)
# Use the following include to make our test apk.
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index 1e78c72e..9fa49957 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -38,7 +38,7 @@
<uses-permission android:name="android.permission.READ_SYNC_SETTINGS" />
<uses-permission android:name="android.permission.RECEIVE_BOOT_COMPLETED" />
<uses-permission android:name="com.google.android.googleapps.permission.GOOGLE_AUTH.mail" />
- <uses-sdk android:minSdkVersion="19" android:targetSdkVersion="29"></uses-sdk>
+ <uses-sdk android:minSdkVersion="19" android:targetSdkVersion="28"></uses-sdk>
<application android:name="CalendarApplication"
diff --git a/proguard.flags b/proguard.flags
index 3f08b97f..923f6382 100644
--- a/proguard.flags
+++ b/proguard.flags
@@ -23,10 +23,6 @@
*** setAnimateTodayAlpha(...);
}
--keep public class * extends android.app.Fragment {
- public <init>();
-}
-
-keepclassmembers class * implements android.content.SharedPreferences$Editor {
public *** apply();
}
diff --git a/res/color/done_text_color.xml b/res/color/done_text_color.xml
deleted file mode 100644
index 85d0e9e9..00000000
--- a/res/color/done_text_color.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<!-- Copyright (C) 2013 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<selector xmlns:android="http://schemas.android.com/apk/res/android">
-
- <item android:state_enabled="false" android:color="@color/done_text_color_disabled"/>
- <item android:color="@color/done_text_color_normal"/>
-
-</selector> \ No newline at end of file
diff --git a/res/color/done_text_color_dark.xml b/res/color/done_text_color_dark.xml
deleted file mode 100644
index 070baf2f..00000000
--- a/res/color/done_text_color_dark.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<!-- Copyright (C) 2013 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<selector xmlns:android="http://schemas.android.com/apk/res/android">
-
- <item android:state_enabled="false" android:color="@color/done_text_color_dark_disabled"/>
- <item android:color="@color/done_text_color_dark_normal"/>
-
-</selector> \ No newline at end of file
diff --git a/res/values/colors.xml b/res/values/colors.xml
index 988bcc4f..2ef7a4bc 100644
--- a/res/values/colors.xml
+++ b/res/values/colors.xml
@@ -167,9 +167,4 @@
<color name="recurrence_picker_background">#fff2f2f2</color>
<color name="recurrence_bubble_text_normal">#ff737373</color>
-
- <color name="done_text_color_normal">#000000</color>
- <color name="done_text_color_disabled">#cccccc</color>
- <color name="done_text_color_dark_normal">#ffffff</color>
- <color name="done_text_color_dark_disabled">#888888</color>
</resources>
diff --git a/res/values/strings.xml b/res/values/strings.xml
index 8c6cf10d..caec61b5 100644
--- a/res/values/strings.xml
+++ b/res/values/strings.xml
@@ -41,7 +41,7 @@
<string name="tomorrow_at_time_fmt">"Tomorrow at <xliff:g id="time_interval">%s</xliff:g>"</string>
<!-- Format string for a date and time description. For ex:
"April 19, 2012, 3:00pm - 4:00pm" [CHAR LIMIT=NONE] -->
- <string name="date_time_fmt">"<xliff:g id="date">%1$s</xliff:g>, <xliff:g id="time_interval">%2$s</xliff:g>"</string>
+ <string name="date_time_fmt">"<xliff:g id="date">%s</xliff:g>, <xliff:g id="time_interval">%s</xliff:g>"</string>
<!-- Some events repeat daily, weekly, monthly, or yearly. This is the label
for all the choices about how often an event repeats (including the choice
diff --git a/src/com/android/calendar/widget/CalendarAppWidgetProvider.java b/src/com/android/calendar/widget/CalendarAppWidgetProvider.java
index 3a69efd3..2864d47a 100644
--- a/src/com/android/calendar/widget/CalendarAppWidgetProvider.java
+++ b/src/com/android/calendar/widget/CalendarAppWidgetProvider.java
@@ -64,11 +64,11 @@ public class CalendarAppWidgetProvider extends AppWidgetProvider {
performUpdate(context, appWidgetManager,
appWidgetManager.getAppWidgetIds(getComponentName(context)),
null /* no eventIds */);
- } else if (action != null && (action.equals(Intent.ACTION_PROVIDER_CHANGED)
+ } else if (action.equals(Intent.ACTION_PROVIDER_CHANGED)
|| action.equals(Intent.ACTION_TIME_CHANGED)
|| action.equals(Intent.ACTION_TIMEZONE_CHANGED)
|| action.equals(Intent.ACTION_DATE_CHANGED)
- || action.equals(Utils.getWidgetScheduledUpdateAction(context)))) {
+ || action.equals(Utils.getWidgetScheduledUpdateAction(context))) {
Intent service = new Intent(context, CalendarAppWidgetService.class);
context.startService(service);
} else {
diff --git a/tests/AndroidTest.xml b/tests/AndroidTest.xml
deleted file mode 100644
index 45f79a6f..00000000
--- a/tests/AndroidTest.xml
+++ /dev/null
@@ -1,30 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<!-- Copyright (C) 2019 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<configuration description="Runs Calendar Tests.">
- <option name="test-suite-tag" value="apct" />
- <option name="test-suite-tag" value="apct-instrumentation" />
- <target_preparer class="com.android.tradefed.targetprep.suite.SuiteApkInstaller">
- <option name="cleanup-apks" value="true" />
- <option name="test-file-name" value="CalendarTests.apk" />
- <option name="test-file-name" value="Calendar.apk" />
- </target_preparer>
-
- <test class="com.android.tradefed.testtype.InstrumentationTest" >
- <option name="package" value="com.android.calendar.tests" />
- <option name="runner" value="android.test.InstrumentationTestRunner" />
- </test>
-</configuration>
-