summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTreehugger Robot <treehugger-gerrit@google.com>2019-04-25 03:13:29 +0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2019-04-25 03:13:29 +0000
commit7b0a800fd47f1b3235c629d1ab0772086124a63f (patch)
treeabcc062f73be037eaa39a62e8470b31e75b71fa5
parent284cf496ed8942ab0c231ce9f45b4fc45b3c7eec (diff)
parent60806f81e72d62be7577fcc43e87c711bd88eb20 (diff)
downloadCalendar-oreo-mr1-iot-release.tar.gz
Merge "AOSP/Calendar -Added TEST_MAPPING file and "LOCAL_COMPATIBILITY_SUITE := general-tests" to enable presubmit tests for Calendar."android-o-mr1-iot-release-1.0.12oreo-mr1-iot-release
-rw-r--r--Android.mk2
-rw-r--r--TEST_MAPPING7
-rw-r--r--tests/Android.mk2
-rw-r--r--tests/AndroidTest.xml30
4 files changed, 41 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 4b5744a7..6598e440 100644
--- a/Android.mk
+++ b/Android.mk
@@ -37,6 +37,8 @@ LOCAL_RESOURCE_DIR := $(addprefix $(LOCAL_PATH)/, $(res_dirs))
LOCAL_PACKAGE_NAME := Calendar
+LOCAL_COMPATIBILITY_SUITE := general-tests
+
LOCAL_PROGUARD_FLAG_FILES := proguard.flags \
../../../frameworks/opt/datetimepicker/proguard.flags
diff --git a/TEST_MAPPING b/TEST_MAPPING
new file mode 100644
index 00000000..31049a6f
--- /dev/null
+++ b/TEST_MAPPING
@@ -0,0 +1,7 @@
+{
+ "presubmit": [
+ {
+ "name": "CalendarTests"
+ }
+ ]
+}
diff --git a/tests/Android.mk b/tests/Android.mk
index bacb8c04..253b813d 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -19,4 +19,6 @@ LOCAL_INSTRUMENTATION_FOR := Calendar
LOCAL_STATIC_JAVA_LIBRARIES := android-common
LOCAL_SDK_VERSION := 16
+LOCAL_COMPATIBILITY_SUITE := general-tests
+
include $(BUILD_PACKAGE)
diff --git a/tests/AndroidTest.xml b/tests/AndroidTest.xml
new file mode 100644
index 00000000..45f79a6f
--- /dev/null
+++ b/tests/AndroidTest.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- Copyright (C) 2019 The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+-->
+<configuration description="Runs Calendar Tests.">
+ <option name="test-suite-tag" value="apct" />
+ <option name="test-suite-tag" value="apct-instrumentation" />
+ <target_preparer class="com.android.tradefed.targetprep.suite.SuiteApkInstaller">
+ <option name="cleanup-apks" value="true" />
+ <option name="test-file-name" value="CalendarTests.apk" />
+ <option name="test-file-name" value="Calendar.apk" />
+ </target_preparer>
+
+ <test class="com.android.tradefed.testtype.InstrumentationTest" >
+ <option name="package" value="com.android.calendar.tests" />
+ <option name="runner" value="android.test.InstrumentationTestRunner" />
+ </test>
+</configuration>
+