summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-12-15 07:22:38 +0000
committerPaul Duffin <paulduffin@google.com>2017-12-15 07:22:38 +0000
commitb11239e2c1a2f4d403595736b298016adc072ac6 (patch)
tree31d0b04b85017872b8cece0db2a71473b7b1d0de /tests
parent0ffa34a887cc56a259dc9904eafcda8f5d452641 (diff)
downloadContacts-b11239e2c1a2f4d403595736b298016adc072ac6.tar.gz
Add android.test.base/stubs dependency
In preparation for the removal of the non-junit classes in the android.test.base library from the android.jar this adds a dependency on android.test.base/stubs to ensure this code will continue to compile. The following change descriptions were generated automatically and so may be a little repetitive. They are provided to give the reviewer enough information to check the comments match what has actually been changed and check the reasoning behind the changes. * tests/Android.mk Added 'android.test.base.stubs' to LOCAL_JAVA_LIBRARIES because ContactsTests's will need them in order to compile once its classes are removed from the current SDK on which it currently depends. Bug: 30188076 Test: make dist Change-Id: I349d64d9cfea78c793c55b8ba42807effc6d401f
Diffstat (limited to 'tests')
-rw-r--r--tests/Android.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index e26408940..a70af4833 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -23,7 +23,7 @@ LOCAL_STATIC_JAVA_LIBRARIES += \
mockito-target-minus-junit4 \
ub-uiautomator
-LOCAL_JAVA_LIBRARIES := android.test.runner.stubs
+LOCAL_JAVA_LIBRARIES := android.test.runner.stubs android.test.base.stubs
LOCAL_AAPT_FLAGS := \
--auto-add-overlay \