summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing Wang <wangying@google.com>2015-05-19 16:10:17 -0700
committerYing Wang <wangying@google.com>2015-05-19 16:10:17 -0700
commit083af06aba7d1d5d3a581f1b404d2df5978e07d3 (patch)
treeed6b66831b06aa3b54d8c9311577ab73e7c4efb2
parenta077ee42ad6a656a064695390e6070cef51ca7f5 (diff)
downloadEmail-083af06aba7d1d5d3a581f1b404d2df5978e07d3.tar.gz
Use $(SUPPORT_LIBRARY_ROOT) to reference support library resource dir.
The build system sets up $(SUPPORT_LIBRARY_ROOT) based on if it's platform build or apps-only build. Change-Id: I81e832138918c729e999690b4c3a215a3c989cfa
-rw-r--r--Android.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Android.mk b/Android.mk
index cfdf52dda..b6a4bd90d 100644
--- a/Android.mk
+++ b/Android.mk
@@ -20,12 +20,12 @@ LOCAL_PATH := $(call my-dir)
include $(CLEAR_VARS)
# Include res dir from chips, unified, emailcommon, and photoviewer
-appcompat_dir := ../../../prebuilts/sdk/current/support/v7/appcompat/res
+appcompat_dir := ../../../$(SUPPORT_LIBRARY_ROOT)/v7/appcompat/res
chips_dir := ../../../frameworks/opt/chips/res
unified_email_dir := ../UnifiedEmail
photo_dir := ../../../frameworks/opt/photoviewer/res ../../../frameworks/opt/photoviewer/appcompat/res
emailcommon_dir := emailcommon
-gridlayout_dir := ../../../prebuilts/sdk/current/support/v7/gridlayout/res
+gridlayout_dir := ../../../$(SUPPORT_LIBRARY_ROOT)/v7/gridlayout/res
bitmap_dir := ../../../frameworks/opt/bitmap/res
datetimepicker_dir := ../../../frameworks/opt/datetimepicker/res
res_dir := res $(unified_email_dir)/res $(chips_dir) $(photo_dir) $(emailcommon_dir)/res $(appcompat_dir) $(gridlayout_dir) $(bitmap_dir) $(datetimepicker_dir)