summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTreehugger Robot <treehugger-gerrit@google.com>2019-07-02 20:07:13 +0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2019-07-02 20:07:13 +0000
commit2fe2bc7ebcc0b47bff169a8cfbde43675da258b9 (patch)
treec7e68d9fc673fc4a767805c449fdb781d2006fe4
parent406e26177c5145f6769efd5fb69adbb3cd5ff092 (diff)
parenteaa57c0971ea6a5dc0269be25aa6fad4b697016c (diff)
downloadEmail-2fe2bc7ebcc0b47bff169a8cfbde43675da258b9.tar.gz
Merge "Migrate packages/apps/Email to androidx.test"
-rw-r--r--tests/Android.mk2
-rw-r--r--tests/AndroidManifest.xml4
-rw-r--r--tests/src/com/android/email/DummyFlakyTest.java3
3 files changed, 5 insertions, 4 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index 5598c2ef9..d5e9d9616 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -24,7 +24,7 @@ include $(CLEAR_VARS)
# We only want this apk build for tests.
LOCAL_MODULE_TAGS := tests
-LOCAL_STATIC_JAVA_LIBRARIES := android-support-test
+LOCAL_STATIC_JAVA_LIBRARIES := androidx.test.rules
# For LOCAL_JAVA_LANGUAGE_VERSION >= 1.7, OpenJDK 9 javac generates synthetic calls to
# Objects.requireNonNull() which was only added in Android API level 19. Thus, this must
diff --git a/tests/AndroidManifest.xml b/tests/AndroidManifest.xml
index 8169f688c..b5e087c37 100644
--- a/tests/AndroidManifest.xml
+++ b/tests/AndroidManifest.xml
@@ -28,9 +28,9 @@
<!--
This declares that this app uses the instrumentation test runner targeting
the package of com.android.email. To run the tests use the command:
- "adb shell am instrument -w com.android.email.tests/android.support.test.runner.AndroidJUnitRunner"
+ "adb shell am instrument -w com.android.email.tests/androidx.test.runner.AndroidJUnitRunner"
-->
- <instrumentation android:name="android.support.test.runner.AndroidJUnitRunner"
+ <instrumentation android:name="androidx.test.runner.AndroidJUnitRunner"
android:targetPackage="com.android.email"
android:label="Tests for Email."/>
diff --git a/tests/src/com/android/email/DummyFlakyTest.java b/tests/src/com/android/email/DummyFlakyTest.java
index a7278b66a..99e37b4e9 100644
--- a/tests/src/com/android/email/DummyFlakyTest.java
+++ b/tests/src/com/android/email/DummyFlakyTest.java
@@ -16,7 +16,8 @@
package com.android.email;
-import android.support.test.filters.FlakyTest;
+import androidx.test.filters.FlakyTest;
+
import org.junit.Test;
/**