summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Mantler <nicoya@google.com>2014-06-30 13:11:03 -0700
committerTony Mantler <nicoya@google.com>2014-06-30 13:13:01 -0700
commit490bf9fbf2c73fb0fda0e122f291a5bb981fcc08 (patch)
tree33bf3c05c0343d3dd6c000544dddd4b7216e7e87
parente04c59dd3af81ce146c9676cbafc2ff685d487a4 (diff)
downloadExchange-490bf9fbf2c73fb0fda0e122f291a5bb981fcc08.tar.gz
Delete obsolete emailsync code
b/5784532 Change-Id: Ia62c10cda81c2495926c2efd02fa40c24bf60abf
-rw-r--r--Android.mk2
-rw-r--r--AndroidManifest.xml5
-rw-r--r--src/com/android/exchange/MeetingResponseRequest.java44
3 files changed, 1 insertions, 50 deletions
diff --git a/Android.mk b/Android.mk
index 7a3de443..662c52fd 100644
--- a/Android.mk
+++ b/Android.mk
@@ -32,7 +32,7 @@ LOCAL_AAPT_FLAGS += --extra-packages com.android.emailcommon
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_SRC_FILES += $(call all-java-files-under, build/src)
-LOCAL_STATIC_JAVA_LIBRARIES := android-common com.android.emailcommon com.android.emailsync
+LOCAL_STATIC_JAVA_LIBRARIES := android-common com.android.emailcommon
LOCAL_STATIC_JAVA_LIBRARIES += calendar-common
LOCAL_STATIC_JAVA_LIBRARIES += android-support-v4
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index 57e65f7f..c81ac360 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -74,11 +74,6 @@
android:theme="@android:style/Theme.Holo.Light"
>
- <receiver
- android:name="com.android.emailsync.EmailSyncAlarmReceiver"/>
- <receiver
- android:name="com.android.emailsync.MailboxAlarmReceiver"/>
-
<service
android:name="com.android.exchange.service.EasService"
android:exported="true">
diff --git a/src/com/android/exchange/MeetingResponseRequest.java b/src/com/android/exchange/MeetingResponseRequest.java
deleted file mode 100644
index 69195fb7..00000000
--- a/src/com/android/exchange/MeetingResponseRequest.java
+++ /dev/null
@@ -1,44 +0,0 @@
-/*
- * Copyright (C) 2010 The Android Open Source Project
- *
- * Licensed under the Apache License, Version 2.0 (the "License");
- * you may not use this file except in compliance with the License.
- * You may obtain a copy of the License at
- *
- * http://www.apache.org/licenses/LICENSE-2.0
- *
- * Unless required by applicable law or agreed to in writing, software
- * distributed under the License is distributed on an "AS IS" BASIS,
- * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- * See the License for the specific language governing permissions and
- * limitations under the License.
- */
-
-package com.android.exchange;
-
-import com.android.emailsync.Request;
-
-/**
- * MeetingResponseRequest is the EAS wrapper for responding to meeting requests.
- */
-public class MeetingResponseRequest extends Request {
- public final int mResponse;
-
- MeetingResponseRequest(long messageId, int response) {
- super(messageId);
- mResponse = response;
- }
-
- // MeetingResponseRequests are unique by their message id (i.e. there's only one response to
- // a given message)
- @Override
- public boolean equals(Object o) {
- if (!(o instanceof MeetingResponseRequest)) return false;
- return ((MeetingResponseRequest)o).mMessageId == mMessageId;
- }
-
- @Override
- public int hashCode() {
- return (int)mMessageId;
- }
-}