summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-12-08 00:02:42 +0000
committerPaul Duffin <paulduffin@google.com>2017-12-08 00:08:29 +0000
commit1ceaeb18b638f14f50db39e82b217d39ff4ef24c (patch)
treed752ae518e58a41a7a4fd885a109a5f6c3fc05a9
parent29a7128376610efd9ad19d121243b2b6ded12af4 (diff)
downloadLauncher2-1ceaeb18b638f14f50db39e82b217d39ff4ef24c.tar.gz
Stop statically including legacy-android-test
Statically including legacy-android-test leads to duplicate classes which causes build time problems (with Proguard) and runtime problems on older SDK versions. This change: * Stops statically including legacy-android-test. * Adds compile time dependencies on andoid.test.base, android.test.mock and android.test.runner where necessary. * Adds <uses-library android:name="android.test.runner"/> to any affected package to ensure that the classes that were included by legacy-android-test are still available at runtime. That also adds a dependency on android.test.base and android.test.mock. The following change descriptions were generated automatically and so may be a little repetitive. They are provided to give the reviewer enough information to check the comments match what has actually been changed and check the reasoning behind the changes. * tests/stress/Android.mk Added 'android.test.base' to LOCAL_JAVA_LIBRARIES because LauncherRotationStressTest's source depends on its classes and because of these changes they are no longer present on the compilation path. Removed legacy-android-test from LOCAL_STATIC_JAVA_LIBRARIES because statically including the classes in LauncherRotationStressTest results in duplicate classes which leads to build time and compile time issues. Bug: 30188076 Test: make checkbuild Change-Id: If5e51968466472529b6dbb5b7cf858d6dce7dc5c
-rw-r--r--tests/stress/Android.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/stress/Android.mk b/tests/stress/Android.mk
index 3c911793..30963e50 100644
--- a/tests/stress/Android.mk
+++ b/tests/stress/Android.mk
@@ -18,8 +18,8 @@ include $(CLEAR_VARS)
# We only want this apk build for tests.
LOCAL_MODULE_TAGS := tests
-LOCAL_JAVA_LIBRARIES := android.test.runner
-LOCAL_STATIC_JAVA_LIBRARIES := junit legacy-android-test
+LOCAL_JAVA_LIBRARIES := android.test.runner android.test.base
+LOCAL_STATIC_JAVA_LIBRARIES := junit
LOCAL_SRC_FILES := $(call all-java-files-under, src)