aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-05-11 23:02:16 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2021-05-11 23:02:16 +0000
commit20d8640ba092f42d4902d7aee922a92945ea6e3a (patch)
tree3b9c0bcfc5a8e9a5dc8786e3166ec6028b466dc2
parent3ca1a1a297a86cf0213899fbfc5f6382dd5229ab (diff)
parente60c3649682a16b5b4af198b1252a00e84e4a4b2 (diff)
downloadMessaging-android-s-beta-5.tar.gz
Original change: https://android-review.googlesource.com/c/platform/packages/apps/Messaging/+/1699267 Change-Id: I0c3cac624e3a8a9b0c395449bf831719fb86184c
-rw-r--r--jni/Android.bp40
-rw-r--r--jni/Android.mk39
2 files changed, 40 insertions, 39 deletions
diff --git a/jni/Android.bp b/jni/Android.bp
new file mode 100644
index 0000000..22840ea
--- /dev/null
+++ b/jni/Android.bp
@@ -0,0 +1,40 @@
+// Copyright (C) 2015 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+cc_library_shared {
+ name: "libgiftranscode",
+ static_libs: ["libgif"],
+ // Link to Android logging (liblog.so) and dynamic linker (libdl.so) libraries
+ shared_libs: [
+ "liblog",
+ "libdl",
+ ],
+ // for including the jni.h file
+ header_libs: ["jni_headers"],
+ include_dirs: ["external/giflib"],
+ srcs: ["GifTranscoder.cpp"],
+ cflags: [
+ "-Wno-unused-parameter",
+ "-Wno-switch",
+ ],
+ sdk_version: "19",
+ // LLVM libc++
+ stl: "c++_static",
+ product_specific: true,
+}
diff --git a/jni/Android.mk b/jni/Android.mk
deleted file mode 100644
index 36edaec..0000000
--- a/jni/Android.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright (C) 2015 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH := $(call my-dir)
-
-include $(CLEAR_VARS)
-
-LOCAL_STATIC_LIBRARIES += libgif
-
-# Link to Android logging (liblog.so) and dynamic linker (libdl.so) libraries
-LOCAL_LDFLAGS := -llog -ldl
-
-LOCAL_C_INCLUDES := \
- external/giflib
-
-LOCAL_MODULE := libgiftranscode
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_SRC_FILES := GifTranscoder.cpp
-
-LOCAL_CFLAGS += -Wall -Werror -Wno-unused-parameter -Wno-switch
-
-LOCAL_SDK_VERSION := 19
-LOCAL_NDK_STL_VARIANT := c++_static # LLVM libc++
-
-LOCAL_PRODUCT_MODULE := true
-
-include $(BUILD_SHARED_LIBRARY)