aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2023-11-08 00:26:39 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2023-11-08 00:26:39 +0000
commiteb9ae2ccc23e5e3227d459f5643be0739051266a (patch)
treeff7fee9bc489f3ec21c187edf45ec0dd4e8a1e9c
parenta5cde15126906131146e9c2f6cd5e9d5a3a57ef2 (diff)
parentcd39324d9f7c9b0c5405fae1c3de3f086a9680d2 (diff)
downloadMessaging-android14-qpr2-release.tar.gz
Change-Id: Ib3ce9f77dc316501843b073a6b671becaaab8ace
-rw-r--r--tests/Android.bp41
-rw-r--r--tests/Android.mk49
2 files changed, 41 insertions, 49 deletions
diff --git a/tests/Android.bp b/tests/Android.bp
new file mode 100644
index 0000000..d4f964b
--- /dev/null
+++ b/tests/Android.bp
@@ -0,0 +1,41 @@
+// Copyright (C) 2023 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_test {
+ name: "messagingtests",
+ srcs: ["src/**/*.java"],
+ instrumentation_for: "messaging",
+ optimize: {
+ enabled: false,
+ },
+ sdk_version: "current",
+ test_suites: ["general-tests"],
+ certificate: "platform",
+ static_libs: ["mockito-target"],
+ libs: [
+ "android.test.mock.stubs",
+ "android.test.runner.stubs",
+ "android.test.base.stubs",
+ ],
+ data: [
+ ":messaging",
+ ],
+}
diff --git a/tests/Android.mk b/tests/Android.mk
deleted file mode 100644
index 0c93ea8..0000000
--- a/tests/Android.mk
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright (C) 2015 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := tests
-
-# Only compile source java files in this apk.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := messagingtests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-LOCAL_INSTRUMENTATION_FOR := messaging
-
-LOCAL_PROGUARD_ENABLED := disabled
-
-# Matching ../Android.mk
-LOCAL_SDK_VERSION := current
-
-LOCAL_COMPATIBILITY_SUITE := general-tests
-
-LOCAL_CERTIFICATE := platform
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- mockito-target
-
-LOCAL_JAVA_LIBRARIES := \
- android.test.mock.stubs \
- android.test.runner.stubs \
- android.test.base.stubs \
-
-
-include $(BUILD_PACKAGE)
-
-include $(call all-makefiles-under,$(LOCAL_PATH))