aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelson Li <nelsonli@google.com>2023-11-07 04:42:30 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2023-11-07 04:42:30 +0000
commit0d952b4e9604ef189e5f3dbda1acac36a3944c03 (patch)
tree892faa9c33d191fa4598baf3e089e1eb04e4e015
parent21ffdb9699d48742a23783aaf792f6816fc39288 (diff)
parent5e271f257b2ee7734a222fa8a7398e35c28bc2cb (diff)
downloadMessaging-0d952b4e9604ef189e5f3dbda1acac36a3944c03.tar.gz
Convert the Android.mk of messagingtest to Android.bp am: ea4310bbc1 am: 5e271f257b
Original change: https://android-review.googlesource.com/c/platform/packages/apps/Messaging/+/2815927 Change-Id: I04c74ac96a985b3c72f3b62e4684094d23701e05 Signed-off-by: Automerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>
-rw-r--r--tests/Android.bp41
-rw-r--r--tests/Android.mk49
2 files changed, 41 insertions, 49 deletions
diff --git a/tests/Android.bp b/tests/Android.bp
new file mode 100644
index 0000000..d4f964b
--- /dev/null
+++ b/tests/Android.bp
@@ -0,0 +1,41 @@
+// Copyright (C) 2023 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_test {
+ name: "messagingtests",
+ srcs: ["src/**/*.java"],
+ instrumentation_for: "messaging",
+ optimize: {
+ enabled: false,
+ },
+ sdk_version: "current",
+ test_suites: ["general-tests"],
+ certificate: "platform",
+ static_libs: ["mockito-target"],
+ libs: [
+ "android.test.mock.stubs",
+ "android.test.runner.stubs",
+ "android.test.base.stubs",
+ ],
+ data: [
+ ":messaging",
+ ],
+}
diff --git a/tests/Android.mk b/tests/Android.mk
deleted file mode 100644
index 0c93ea8..0000000
--- a/tests/Android.mk
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright (C) 2015 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := tests
-
-# Only compile source java files in this apk.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := messagingtests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-LOCAL_INSTRUMENTATION_FOR := messaging
-
-LOCAL_PROGUARD_ENABLED := disabled
-
-# Matching ../Android.mk
-LOCAL_SDK_VERSION := current
-
-LOCAL_COMPATIBILITY_SUITE := general-tests
-
-LOCAL_CERTIFICATE := platform
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- mockito-target
-
-LOCAL_JAVA_LIBRARIES := \
- android.test.mock.stubs \
- android.test.runner.stubs \
- android.test.base.stubs \
-
-
-include $(BUILD_PACKAGE)
-
-include $(call all-makefiles-under,$(LOCAL_PATH))