summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:12:11 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 16:12:11 +0000
commit2e3b71e7a715bbe17bd732c6dbb4325c7fffd00f (patch)
treeba302ad1951f108fa13fb7be9a765beda75b3f4d
parent1eabf23efa9b3e6c68fb30195e0c3fd10dd57d04 (diff)
downloadOneTimeInitializer-2e3b71e7a715bbe17bd732c6dbb4325c7fffd00f.tar.gz
packages/apps/OneTimeInitializer: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I5c82c84ef5bf6c3d752f53fd6fee0f2b038ae4bf
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 7b4bf91..1956fcd 100644
--- a/Android.mk
+++ b/Android.mk
@@ -24,6 +24,7 @@ LOCAL_SRC_FILES := $(call all-java-files-under,src)
LOCAL_STATIC_JAVA_LIBRARIES += android-common
LOCAL_PACKAGE_NAME := OneTimeInitializer
+LOCAL_SDK_VERSION := current
LOCAL_PRIVILEGED_MODULE := true