summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-11 20:30:38 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-11 20:30:38 -0800
commit9d88fad54526d02c6abb01c63ef8cd8a71f8a578 (patch)
treed1483cd203b3c2e9c0b5484ddf4530706921fcd6
parentbceb908b79a5268343fb8449aab42d5cdf7f0365 (diff)
parent501a44bcd3d3cf2698cda7d15508e1ba57ce1aac (diff)
downloadOneTimeInitializer-9d88fad54526d02c6abb01c63ef8cd8a71f8a578.tar.gz
Merge "Convert Android.mk file to Android.bp" am: 747cd94568
am: 501a44bcd3 Change-Id: I6abff2a1a0585806aadca099d49ca4026c9fadb1
-rw-r--r--Android.bp26
-rw-r--r--Android.mk33
2 files changed, 26 insertions, 33 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..bb17699
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,26 @@
+//
+// Copyright (C) 2012 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+android_app {
+ name: "OneTimeInitializer",
+ srcs: ["src/**/*.java"],
+ static_libs: ["android-common"],
+ sdk_version: "current",
+ privileged: true,
+ optimize: {
+ proguard_flags_files: ["proguard.flags"],
+ },
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index 1956fcd..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (C) 2012 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_SRC_FILES := $(call all-java-files-under,src)
-
-LOCAL_STATIC_JAVA_LIBRARIES += android-common
-
-LOCAL_PACKAGE_NAME := OneTimeInitializer
-LOCAL_SDK_VERSION := current
-
-LOCAL_PRIVILEGED_MODULE := true
-
-LOCAL_PROGUARD_FLAG_FILES := proguard.flags
-
-include $(BUILD_PACKAGE)