summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTreehugger Robot <treehugger-gerrit@google.com>2019-01-12 04:14:23 +0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2019-01-12 04:14:23 +0000
commitc6ef1d2dc0a9d3d73217868e694f14ed3c5c65fc (patch)
tree36bfb650d3335f913200d82487f218327e374f99
parent1e5d8a500dce6530a99cb952681889042dcfb63a (diff)
parent9066323a3cf74a0fd201161bd22650025e9856d5 (diff)
downloadProtips-c6ef1d2dc0a9d3d73217868e694f14ed3c5c65fc.tar.gz
Merge "Convert Android.mk file to Android.bp"
-rw-r--r--Android.bp6
-rw-r--r--Android.mk16
2 files changed, 6 insertions, 16 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..b0b543a
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,6 @@
+android_app {
+ name: "Protips",
+ // Only compile source java files in this apk.
+ srcs: ["src/**/*.java"],
+ sdk_version: "current",
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index 467634d..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-# Only compile source java files in this apk.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := Protips
-
-LOCAL_SDK_VERSION := current
-
-include $(BUILD_PACKAGE)
-
-# Use the following include to make our test apk.
-include $(call all-makefiles-under,$(LOCAL_PATH))