summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Tate <ctate@google.com>2016-05-12 16:18:16 -0700
committerChristopher Tate <ctate@google.com>2016-05-13 13:17:15 -0700
commit356bff898c6f33334d20ea68bd5c49f7a2ef9b6b (patch)
tree62f731b4de9555f56b161872ed174c79e6b42e22
parent78ca0db658fe6253d506916e36319e620476f809 (diff)
downloadProvision-nougat-dev.tar.gz
...which means it needs to declare so in its ACTION_MAIN intent filter as well as be installed as 'privileged,' otherwise it will not be permitted to request elevated priority for that intent filter. Bug 28748710 Change-Id: Ic6b0f440ab67d2ad65c962b129a4e5b149c374d5
-rw-r--r--Android.mk1
-rw-r--r--AndroidManifest.xml1
2 files changed, 2 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 1be3f23..e03490f 100644
--- a/Android.mk
+++ b/Android.mk
@@ -7,6 +7,7 @@ LOCAL_SRC_FILES := $(call all-subdir-java-files)
LOCAL_PACKAGE_NAME := Provision
LOCAL_CERTIFICATE := platform
+LOCAL_PRIVILEGED_MODULE := true
LOCAL_PROGUARD_FLAG_FILES := proguard.flags
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index 585e9cc..8360578 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -30,6 +30,7 @@
<action android:name="android.intent.action.MAIN" />
<category android:name="android.intent.category.HOME" />
<category android:name="android.intent.category.DEFAULT" />
+ <category android:name="android.intent.category.SETUP_WIZARD" />
</intent-filter>
</activity>
</application>