summaryrefslogtreecommitdiff
path: root/tests/anomaly-tester
diff options
context:
space:
mode:
authorBrett Chabot <brettchabot@google.com>2018-12-13 19:06:32 -0800
committerBrett Chabot <brettchabot@google.com>2018-12-17 09:20:05 -0800
commit031dcf5019d31dfaf0569c931cbfdcffaa206329 (patch)
treeb57653673f324391296c6bd2f0c8e23f54c5b26d /tests/anomaly-tester
parent8920ec68f926b6b0fde05ece94aa34e726cc3c79 (diff)
downloadSettings-031dcf5019d31dfaf0569c931cbfdcffaa206329.tar.gz
Migrate packages/apps/Settings to androidx.test
See go/jetpack-test-android-migration Test: make checkbuild Change-Id: If67b124188fd4e303154eb11263d03abfb3718c6
Diffstat (limited to 'tests/anomaly-tester')
-rw-r--r--tests/anomaly-tester/Android.mk2
-rw-r--r--tests/anomaly-tester/AndroidManifest.xml2
-rw-r--r--tests/anomaly-tester/src/com/android/settings/anomaly/tests/BluetoothAnomalyTest.java5
-rw-r--r--tests/anomaly-tester/src/com/android/settings/anomaly/tests/WakelockAnomalyTest.java5
4 files changed, 8 insertions, 6 deletions
diff --git a/tests/anomaly-tester/Android.mk b/tests/anomaly-tester/Android.mk
index 9a0a8755163..4dffeab0500 100644
--- a/tests/anomaly-tester/Android.mk
+++ b/tests/anomaly-tester/Android.mk
@@ -7,7 +7,7 @@ LOCAL_CERTIFICATE := platform
LOCAL_JAVA_LIBRARIES := android.test.runner
LOCAL_STATIC_JAVA_LIBRARIES := \
- android-support-test \
+ androidx.test.rules \
mockito-target \
ub-uiautomator \
truth-prebuilt \
diff --git a/tests/anomaly-tester/AndroidManifest.xml b/tests/anomaly-tester/AndroidManifest.xml
index 7893b866bfa..d6f68a892c1 100644
--- a/tests/anomaly-tester/AndroidManifest.xml
+++ b/tests/anomaly-tester/AndroidManifest.xml
@@ -44,7 +44,7 @@
</application>
<instrumentation
- android:name="android.support.test.runner.AndroidJUnitRunner"
+ android:name="androidx.test.runner.AndroidJUnitRunner"
android:targetPackage="com.android.settings"
android:label="Settings Test Cases">
</instrumentation>
diff --git a/tests/anomaly-tester/src/com/android/settings/anomaly/tests/BluetoothAnomalyTest.java b/tests/anomaly-tester/src/com/android/settings/anomaly/tests/BluetoothAnomalyTest.java
index 3630ce420dd..0477e094228 100644
--- a/tests/anomaly-tester/src/com/android/settings/anomaly/tests/BluetoothAnomalyTest.java
+++ b/tests/anomaly-tester/src/com/android/settings/anomaly/tests/BluetoothAnomalyTest.java
@@ -19,13 +19,14 @@ import static com.google.common.truth.Truth.assertWithMessage;
import android.app.Instrumentation;
import android.content.Context;
import android.content.Intent;
-import android.support.test.InstrumentationRegistry;
-import android.support.test.runner.AndroidJUnit4;
import android.support.test.uiautomator.By;
import android.support.test.uiautomator.UiDevice;
import android.support.test.uiautomator.Until;
import android.text.format.DateUtils;
+import androidx.test.InstrumentationRegistry;
+import androidx.test.runner.AndroidJUnit4;
+
import org.junit.After;
import org.junit.Before;
import org.junit.Test;
diff --git a/tests/anomaly-tester/src/com/android/settings/anomaly/tests/WakelockAnomalyTest.java b/tests/anomaly-tester/src/com/android/settings/anomaly/tests/WakelockAnomalyTest.java
index a2f38048977..c44e2eaf712 100644
--- a/tests/anomaly-tester/src/com/android/settings/anomaly/tests/WakelockAnomalyTest.java
+++ b/tests/anomaly-tester/src/com/android/settings/anomaly/tests/WakelockAnomalyTest.java
@@ -19,13 +19,14 @@ import static com.google.common.truth.Truth.assertWithMessage;
import android.app.Instrumentation;
import android.content.Context;
import android.content.Intent;
-import android.support.test.InstrumentationRegistry;
-import android.support.test.runner.AndroidJUnit4;
import android.support.test.uiautomator.By;
import android.support.test.uiautomator.UiDevice;
import android.support.test.uiautomator.Until;
import android.text.format.DateUtils;
+import androidx.test.InstrumentationRegistry;
+import androidx.test.runner.AndroidJUnit4;
+
import org.junit.After;
import org.junit.Before;
import org.junit.Test;