summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:12:30 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 16:12:30 +0000
commitbbc59491943f8114e816cb994f46c6446c2b8699 (patch)
treee064d345b8d3ba462139600fe344a0f4f547d717
parentba7237540f779f1c7e67ae7a36aa7a63da8eb1c5 (diff)
downloadSoundRecorder-bbc59491943f8114e816cb994f46c6446c2b8699.tar.gz
packages/apps/SoundRecorder: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I5a7eeb510ef5dfff4591be715beda17c7c1b0e9a
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 51eba9e..0154231 100644
--- a/Android.mk
+++ b/Android.mk
@@ -6,5 +6,6 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-subdir-java-files)
LOCAL_PACKAGE_NAME := SoundRecorder
+LOCAL_SDK_VERSION := current
include $(BUILD_PACKAGE)