summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Onorato <joeo@google.com>2011-04-06 18:25:45 -0700
committerJoe Onorato <joeo@google.com>2011-04-06 18:26:59 -0700
commit10f05a57805c5409f990959dcad25c67a82ec16d (patch)
tree4f09dd9cdddf1c9a88aa959bd11b56f8fb00d3c3
parent7277e821713196510586cdf5fd334cdc012554b2 (diff)
downloadSpareParts-10f05a57805c5409f990959dcad25c67a82ec16d.tar.gz
Change-Id: If0deaf75944d01ad8c276b96e10163a766a2ef45
-rw-r--r--Android.mk2
-rw-r--r--AndroidManifest.xml11
-rw-r--r--src/com/android/spare_parts/Enabler.java44
3 files changed, 55 insertions, 2 deletions
diff --git a/Android.mk b/Android.mk
index 1a1ea0a..a6ab6e9 100644
--- a/Android.mk
+++ b/Android.mk
@@ -1,7 +1,7 @@
LOCAL_PATH:= $(call my-dir)
include $(CLEAR_VARS)
-LOCAL_MODULE_TAGS := eng
+LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-subdir-java-files)
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index 137f907..e311197 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -23,7 +23,9 @@
<application android:label="@string/app_label"
android:icon="@mipmap/app_icon">
- <activity android:name="SpareParts">
+ <activity
+ android:name="SpareParts"
+ android:enabled="false">
<intent-filter>
<action android:name="android.intent.action.MAIN" />
<category android:name="android.intent.category.DEFAULT" />
@@ -31,5 +33,12 @@
</intent-filter>
</activity>
+ <receiver
+ android:name="Enabler">
+ <intent-filter>
+ <action android:name="android.intent.action.ADVANCED_SETTINGS" />
+ </intent-filter>
+ </receiver>
+
</application>
</manifest>
diff --git a/src/com/android/spare_parts/Enabler.java b/src/com/android/spare_parts/Enabler.java
new file mode 100644
index 0000000..3769555
--- /dev/null
+++ b/src/com/android/spare_parts/Enabler.java
@@ -0,0 +1,44 @@
+/*
+ * Copyright (C) 2011 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.spare_parts;
+
+import android.bluetooth.BluetoothAdapter;
+import android.content.BroadcastReceiver;
+import android.content.ComponentName;
+import android.content.Context;
+import android.content.Intent;
+import android.content.pm.PackageManager;
+import android.provider.Settings;
+import android.util.Log;
+
+public final class Enabler extends BroadcastReceiver {
+ private static final String TAG = "SpareParts.Enabler";
+
+ @Override
+ public void onReceive(Context context, Intent intent) {
+ String action = intent.getAction();
+ boolean enabled = intent.getIntExtra("state",
+ Settings.System.ADVANCED_SETTINGS_DEFAULT) != 0;
+ final PackageManager pm = context.getPackageManager();
+ final ComponentName componentName = new ComponentName(context, SpareParts.class);
+ final int value = enabled
+ ? PackageManager.COMPONENT_ENABLED_STATE_ENABLED
+ : PackageManager.COMPONENT_ENABLED_STATE_DEFAULT;
+ pm.setComponentEnabledSetting(componentName, value, PackageManager.DONT_KILL_APP);
+ }
+}
+