aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandroid-build-team Robot <android-build-team-robot@google.com>2021-05-11 01:08:27 +0000
committerandroid-build-team Robot <android-build-team-robot@google.com>2021-05-11 01:08:27 +0000
commit24c88d3101c7a6f40b106489f583ca50b37dfa4a (patch)
tree0f7f1db0ccb17c9cae5cf514ee2c892d98980222
parent1b697d69cbee5298482e68a6da05139ef876b2a9 (diff)
parent0c6bc3c6f3884fe45b748c6604aa5a489ecd9397 (diff)
downloadTV-android12-d1-s5-release.tar.gz
Change-Id: I1498123be3fdce336e505f57987a7ff364c34f14
-rw-r--r--partner_support/sample_customization/Android.bp16
-rw-r--r--partner_support/sample_customization/Android.mk20
2 files changed, 16 insertions, 20 deletions
diff --git a/partner_support/sample_customization/Android.bp b/partner_support/sample_customization/Android.bp
new file mode 100644
index 00000000..f428f402
--- /dev/null
+++ b/partner_support/sample_customization/Android.bp
@@ -0,0 +1,16 @@
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+android_app {
+ name: "PartnerSupportSampleCustomization",
+ optimize: {
+ enabled: false,
+ },
+ // Overlay view related functionality requires system APIs.
+ sdk_version: "system_current",
+ min_sdk_version: "23",
+ // Required for customization
+ privileged: true,
+}
diff --git a/partner_support/sample_customization/Android.mk b/partner_support/sample_customization/Android.mk
deleted file mode 100644
index e74a9268..00000000
--- a/partner_support/sample_customization/Android.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_PACKAGE_NAME := PartnerSupportSampleCustomization
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_PROGUARD_ENABLED := disabled
-# Overlay view related functionality requires system APIs.
-LOCAL_SDK_VERSION := system_current
-LOCAL_MIN_SDK_VERSION := 23 # M
-
-# Required for customization
-LOCAL_PRIVILEGED_MODULE := true
-
-LOCAL_RESOURCE_DIR := \
- $(LOCAL_PATH)/res
-
-include $(BUILD_PACKAGE)