aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-05-10 22:20:53 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2021-05-10 22:20:53 +0000
commit8a5f894ef1c112b4da5de3aed01a793541f967bf (patch)
tree0f7f1db0ccb17c9cae5cf514ee2c892d98980222
parent62ae1898798c94e3cfbe7e72d29046fe090a1207 (diff)
parent0c6bc3c6f3884fe45b748c6604aa5a489ecd9397 (diff)
downloadTV-android12L-d2-s3-release.tar.gz
Original change: https://android-review.googlesource.com/c/platform/packages/apps/TV/+/1689287 Change-Id: If5de86d04b27806b9f068185398d3c2c3ba2fd55
-rw-r--r--partner_support/sample_customization/Android.bp16
-rw-r--r--partner_support/sample_customization/Android.mk20
2 files changed, 16 insertions, 20 deletions
diff --git a/partner_support/sample_customization/Android.bp b/partner_support/sample_customization/Android.bp
new file mode 100644
index 00000000..f428f402
--- /dev/null
+++ b/partner_support/sample_customization/Android.bp
@@ -0,0 +1,16 @@
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+android_app {
+ name: "PartnerSupportSampleCustomization",
+ optimize: {
+ enabled: false,
+ },
+ // Overlay view related functionality requires system APIs.
+ sdk_version: "system_current",
+ min_sdk_version: "23",
+ // Required for customization
+ privileged: true,
+}
diff --git a/partner_support/sample_customization/Android.mk b/partner_support/sample_customization/Android.mk
deleted file mode 100644
index e74a9268..00000000
--- a/partner_support/sample_customization/Android.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_PACKAGE_NAME := PartnerSupportSampleCustomization
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_PROGUARD_ENABLED := disabled
-# Overlay view related functionality requires system APIs.
-LOCAL_SDK_VERSION := system_current
-LOCAL_MIN_SDK_VERSION := 23 # M
-
-# Required for customization
-LOCAL_PRIVILEGED_MODULE := true
-
-LOCAL_RESOURCE_DIR := \
- $(LOCAL_PATH)/res
-
-include $(BUILD_PACKAGE)