aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2024-02-03 00:00:37 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2024-02-03 00:00:37 +0000
commit5f5d33865410bf02a551ed0b2491e4b696faec83 (patch)
tree6556680d008fa03b22224fe9c219e3bb50e60b1d
parent3d4e19e4595d9e79a8c0ddae2a988f39e71e968c (diff)
parentc29ad43511bd68ef9de604baca9654675668f0e3 (diff)
downloadTV-simpleperf-release.tar.gz
Snap for 11400057 from c29ad43511bd68ef9de604baca9654675668f0e3 to simpleperf-releasesimpleperf-release
Change-Id: I979bc22f14f22e80ab30808d6de15733c448c118
-rw-r--r--Android.bp3
-rw-r--r--AndroidManifest.xml2
-rw-r--r--common/Android.bp28
-rw-r--r--common/tests/robotests/Android.bp48
-rw-r--r--common/tests/robotests/Android.mk54
-rw-r--r--src/com/android/tv/TvApplication.java4
-rw-r--r--tests/Android.bp45
-rw-r--r--tests/Android.mk1
-rw-r--r--tests/common/Android.bp26
-rw-r--r--tests/common/Android.mk28
-rw-r--r--tests/robotests/Android.bp53
-rw-r--r--tests/robotests/Android.mk78
-rw-r--r--tests/robotests/src/com/android/tv/testing/TvRobolectricTestRunner.java1
-rw-r--r--tests/unit/Android.mk32
-rw-r--r--tuner/Android.bp3
-rw-r--r--tuner/tests/robotests/Android.bp47
-rw-r--r--tuner/tests/robotests/Android.mk72
-rw-r--r--tuner/tests/robotests/javatests/com/android/tv/tuner/testing/TvTunerRobolectricTestRunner.java1
18 files changed, 244 insertions, 282 deletions
diff --git a/Android.bp b/Android.bp
index 951d6b0e..6abdb3c1 100644
--- a/Android.bp
+++ b/Android.bp
@@ -112,6 +112,9 @@ android_app {
"--extra-packages",
"com.android.tv.common",
],
+ lint: {
+ baseline_filename: "lint-baseline.xml",
+ },
}
prebuilt_etc {
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index 6a2d435f..7f5be2e5 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -24,6 +24,7 @@
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>
<uses-permission android:name="android.permission.CHANGE_HDMI_CEC_ACTIVE_SOURCE"/>
<uses-permission android:name="android.permission.FOREGROUND_SERVICE"/>
+ <uses-permission android:name="android.permission.FOREGROUND_SERVICE_MEDIA_PLAYBACK"/>
<uses-permission android:name="android.permission.HDMI_CEC"/>
<uses-permission android:name="android.permission.INTERNET"/>
<uses-permission android:name="android.permission.MODIFY_PARENTAL_CONTROLS"/>
@@ -278,6 +279,7 @@
</intent-filter>
</activity> <!-- DVR -->
<service android:name="com.android.tv.dvr.recorder.DvrRecordingService"
+ android:foregroundServiceType="mediaPlayback"
android:exported="false"
android:label="@string/dvr_service_name"/>
diff --git a/common/Android.bp b/common/Android.bp
index f6ba940c..acc614a3 100644
--- a/common/Android.bp
+++ b/common/Android.bp
@@ -41,18 +41,18 @@ android_library {
],
static_libs: [
- "androidx.legacy_legacy-support-core-ui",
- "androidx.appcompat_appcompat",
- "androidx.preference_preference",
- "androidx.leanback_leanback",
- "androidx.tvprovider_tvprovider",
- "tv-guava-android-jar",
- "tv-guava-failureaccess-jar",
- "jsr330",
- "tv-lib-dagger",
- "tv-lib-exoplayer",
- "tv-lib-exoplayer-v2-core",
- "tv-lib-dagger-android",
+ "androidx.legacy_legacy-support-core-ui",
+ "androidx.appcompat_appcompat",
+ "androidx.preference_preference",
+ "androidx.leanback_leanback",
+ "androidx.tvprovider_tvprovider",
+ "tv-guava-android-jar",
+ "tv-guava-failureaccess-jar",
+ "jsr330",
+ "tv-lib-dagger",
+ "tv-lib-exoplayer",
+ "tv-lib-exoplayer-v2-core",
+ "tv-lib-dagger-android",
],
plugins: [
@@ -62,8 +62,10 @@ android_library {
"tv-lib-dagger-compiler",
],
-
min_sdk_version: "23",
+ lint: {
+ baseline_filename: "lint-baseline.xml",
+ },
// TODO(b/77284273): generate build config after dagger supports libraries
//include $(LOCAL_PATH)/buildconfig.mk
diff --git a/common/tests/robotests/Android.bp b/common/tests/robotests/Android.bp
new file mode 100644
index 00000000..4ce4e3df
--- /dev/null
+++ b/common/tests/robotests/Android.bp
@@ -0,0 +1,48 @@
+//
+// Copyright (C) 2023 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_robolectric_test {
+ name: "TvCommonRoboTests",
+ srcs: [
+ "src/**/*.java",
+ ],
+ java_resource_dirs: ["config"],
+ libs: [
+ "diffutils-prebuilt-jar",
+ ],
+ static_libs: [
+ "tv-lib-truth",
+ "androidx.test.ext.truth",
+ "tv-test-common",
+ "tv-test-common-robo",
+ ],
+ plugins: [
+ "tv-lib-dagger-android-processor",
+ "tv-lib-dagger-compiler",
+ ],
+ instrumentation_for: "LiveTv",
+ test_options: {
+ timeout: 36000,
+ },
+ upstream: true,
+}
diff --git a/common/tests/robotests/Android.mk b/common/tests/robotests/Android.mk
deleted file mode 100644
index 85512fb6..00000000
--- a/common/tests/robotests/Android.mk
+++ /dev/null
@@ -1,54 +0,0 @@
-#############################################################
-# Tv Common Robolectric test target. #
-#############################################################
-LOCAL_PATH := $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE := TvCommonRoboTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_CLASS := JAVA_LIBRARIES
-
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_JAVA_LIBRARIES := \
- Robolectric_all-target \
- mockito-robolectric-prebuilt \
- robolectric_android-all-stub \
- diffutils-prebuilt-jar \
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- tv-lib-truth \
-
-LOCAL_STATIC_ANDROID_LIBRARIES := \
- androidx.test.ext.truth \
- tv-test-common \
- tv-test-common-robo \
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-
-LOCAL_MODULE_TAGS := optional
-
-include $(BUILD_STATIC_JAVA_LIBRARY)
-
-#############################################################
-# Tv common runner target to run the previous target. #
-#############################################################
-include $(CLEAR_VARS)
-LOCAL_MODULE := RunTvCommonRoboTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-LOCAL_ROBOTEST_FILES := $(call find-files-in-subdirs,$(LOCAL_PATH)/src,*Test.java,.)
-
-LOCAL_JAVA_LIBRARIES := \
- TvCommonRoboTests \
- Robolectric_all-target \
- mockito-robolectric-prebuilt \
- robolectric_android-all-stub \
-
-LOCAL_TEST_PACKAGE := LiveTv
-
-LOCAL_ROBOTEST_TIMEOUT := 36000
-
-include external/robolectric-shadows/run_robotests.mk
diff --git a/src/com/android/tv/TvApplication.java b/src/com/android/tv/TvApplication.java
index 5ab8f033..c5e4f32e 100644
--- a/src/com/android/tv/TvApplication.java
+++ b/src/com/android/tv/TvApplication.java
@@ -255,7 +255,9 @@ public abstract class TvApplication extends BaseApplication implements TvSinglet
@Override
@Nullable
public DvrManager getDvrManager() {
- return (CommonFeatures.DVR.isEnabled(this)) ? mDvrManager.get() : null;
+ return (CommonFeatures.DVR.isEnabled(this) && mDvrScheduleManager != null)
+ ? mDvrManager.get()
+ : null;
}
/** Returns the {@link DvrScheduleManager}. */
diff --git a/tests/Android.bp b/tests/Android.bp
new file mode 100644
index 00000000..f09cbfb7
--- /dev/null
+++ b/tests/Android.bp
@@ -0,0 +1,45 @@
+//
+// Copyright (C) 2023 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_test {
+ name: "TVUnitTests",
+ package_name: "com.android.tv.tests",
+ srcs: ["unit/src/**/*.java"],
+ static_libs: [
+ "androidx.test.runner",
+ "mockito-target",
+ "tv-test-common",
+ ],
+ libs: [
+ "android.test.runner.stubs",
+ "android.test.base.stubs",
+ "android.test.mock.stubs",
+ ],
+ manifest: "unit/AndroidManifest.xml",
+ resource_dirs: ["common/res"],
+ instrumentation_for: "LiveTv",
+ sdk_version: "system_current",
+ optimize: {
+ enabled: false,
+ },
+}
diff --git a/tests/Android.mk b/tests/Android.mk
deleted file mode 100644
index 5053e7d6..00000000
--- a/tests/Android.mk
+++ /dev/null
@@ -1 +0,0 @@
-include $(call all-subdir-makefiles)
diff --git a/tests/common/Android.bp b/tests/common/Android.bp
index 4e194a63..ae00673c 100644
--- a/tests/common/Android.bp
+++ b/tests/common/Android.bp
@@ -35,7 +35,7 @@ android_library {
"mockito-robolectric-prebuilt",
"tv-lib-truth",
"androidx.test.uiautomator_uiautomator",
- "Robolectric_all-target",
+ "Robolectric_all-target_upstream",
],
// Link tv-common as shared library to avoid the problem of initialization of the constants
@@ -52,3 +52,27 @@ android_library {
},
}
+
+android_library {
+ name: "tv-test-common-robo",
+ srcs: [
+ "src/com/android/tv/testing/robo/**/*.java",
+ "src/com/android/tv/testing/shadows/**/*.java",
+ ],
+ static_libs: [
+ "Robolectric_all-target_upstream",
+ "mockito-robolectric-prebuilt",
+ "tv-test-common",
+ ],
+ // Disable dexpreopt and <uses-library> check for test.
+ enforce_uses_libs: false,
+ dex_preopt: {
+ enabled: false,
+ },
+ resource_dirs: [
+ "res",
+ ],
+ libs: [
+ "LiveTv",
+ ],
+}
diff --git a/tests/common/Android.mk b/tests/common/Android.mk
deleted file mode 100644
index 7a232ff7..00000000
--- a/tests/common/Android.mk
+++ /dev/null
@@ -1,28 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE := tv-test-common-robo
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-LOCAL_SRC_FILES := \
- $(call all-java-files-under, src/com/android/tv/testing/robo) \
- $(call all-java-files-under, src/com/android/tv/testing/shadows)
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- robolectric_android-all-stub \
- Robolectric_all-target \
- mockito-robolectric-prebuilt \
- tv-test-common \
-
-# Disable dexpreopt and <uses-library> check for test.
-LOCAL_ENFORCE_USES_LIBRARIES := false
-LOCAL_DEX_PREOPT := false
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-
-LOCAL_MODULE_TAGS := optional
-
-include $(BUILD_STATIC_JAVA_LIBRARY)
diff --git a/tests/robotests/Android.bp b/tests/robotests/Android.bp
new file mode 100644
index 00000000..02015bed
--- /dev/null
+++ b/tests/robotests/Android.bp
@@ -0,0 +1,53 @@
+//
+// Copyright 2023, The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_robolectric_test {
+ name: "TvRoboTests",
+ srcs: [
+ "src/**/*.java",
+ ],
+ exclude_srcs: [
+ "src/com/android/tv/data/epg/EpgFetcherImplTest.java",
+ "src/com/android/tv/guide/ProgramItemViewTest.java",
+ ],
+ static_libs: [
+ "tv-lib-dagger",
+ "tv-lib-truth",
+ "android-support-annotations",
+ "androidx.leanback_leanback-nodeps",
+ "androidx.test.core",
+ "androidx.test.ext.truth",
+ "tv-lib-dagger-android",
+ "tv-test-common",
+ "tv-test-common-robo",
+ ],
+ plugins: [
+ "tv-lib-dagger-android-processor",
+ "tv-lib-dagger-compiler",
+ ],
+ instrumentation_for: "LiveTv",
+ test_options: {
+ timeout: 36000,
+ },
+ upstream: true,
+}
diff --git a/tests/robotests/Android.mk b/tests/robotests/Android.mk
deleted file mode 100644
index c5341ab8..00000000
--- a/tests/robotests/Android.mk
+++ /dev/null
@@ -1,78 +0,0 @@
-#############################################################
-# Tv Robolectric test target. #
-#############################################################
-LOCAL_PATH := $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE := TvRoboTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_CLASS := JAVA_LIBRARIES
-
-BASE_DIR = src/com/android/tv
-EXCLUDE_FILES := \
- $(BASE_DIR)/data/epg/EpgFetcherImplTest.java \
- $(BASE_DIR)/guide/ProgramItemViewTest.java \
-
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-LOCAL_SRC_FILES := $(filter-out $(EXCLUDE_FILES),$(LOCAL_SRC_FILES))
-
-LOCAL_JAVA_LIBRARIES := \
- Robolectric_all-target \
- mockito-robolectric-prebuilt \
- robolectric_android-all-stub \
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- tv-lib-dagger \
- tv-lib-truth \
-
-LOCAL_STATIC_ANDROID_LIBRARIES := \
- androidx.leanback_leanback-nodeps \
- androidx.test.core \
- androidx.test.ext.truth \
- tv-lib-dagger-android \
- tv-test-common \
- tv-test-common-robo \
-
-LOCAL_ANNOTATION_PROCESSORS := \
- tv-lib-dagger-android-processor \
- tv-lib-dagger-compiler \
-
-LOCAL_ANNOTATION_PROCESSOR_CLASSES := \
- dagger.internal.codegen.ComponentProcessor,dagger.android.processor.AndroidProcessor
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-
-LOCAL_MODULE_TAGS := optional
-
-include $(BUILD_STATIC_JAVA_LIBRARY)
-
-#############################################################
-# Tv runner target to run the previous target. #
-#############################################################
-include $(CLEAR_VARS)
-LOCAL_MODULE := RunTvRoboTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-BASE_DIR = com/android/tv
-EXCLUDE_FILES := \
- $(BASE_DIR)/data/epg/EpgFetcherImplTest.java \
- $(BASE_DIR)/guide/ProgramItemViewTest.java \
-
-LOCAL_ROBOTEST_FILES := $(call find-files-in-subdirs,$(LOCAL_PATH)/src,*Test.java,.)
-LOCAL_ROBOTEST_FILES := $(filter-out $(EXCLUDE_FILES),$(LOCAL_ROBOTEST_FILES))
-
-LOCAL_JAVA_LIBRARIES := \
- Robolectric_all-target \
- TvRoboTests \
- mockito-robolectric-prebuilt \
- robolectric_android-all-stub \
- tv-test-common \
- tv-test-common-robo \
-
-LOCAL_TEST_PACKAGE := LiveTv
-
-LOCAL_ROBOTEST_TIMEOUT := 36000
-
-include external/robolectric-shadows/run_robotests.mk
diff --git a/tests/robotests/src/com/android/tv/testing/TvRobolectricTestRunner.java b/tests/robotests/src/com/android/tv/testing/TvRobolectricTestRunner.java
index 93813c08..d1c16a8d 100644
--- a/tests/robotests/src/com/android/tv/testing/TvRobolectricTestRunner.java
+++ b/tests/robotests/src/com/android/tv/testing/TvRobolectricTestRunner.java
@@ -44,7 +44,6 @@ public class TvRobolectricTestRunner extends RobolectricTestRunner {
* We are going to create our own custom manifest so that we can add multiple resource paths to
* it. This lets us access resources in both Settings and SettingsLib in our tests.
*/
- @Override
protected AndroidManifest getAppManifest(Config config) {
final String packageName = "com.android.tv";
diff --git a/tests/unit/Android.mk b/tests/unit/Android.mk
deleted file mode 100644
index 6123af7b..00000000
--- a/tests/unit/Android.mk
+++ /dev/null
@@ -1,32 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := tests
-
-
-# Include all test java files.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- androidx.test.runner \
- mockito-robolectric-prebuilt \
- tv-test-common \
-
-LOCAL_JAVA_LIBRARIES := \
- android.test.runner.stubs \
- android.test.base.stubs \
- android.test.mock.stubs \
-
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/../common/res
-
-LOCAL_PACKAGE_NAME := TVUnitTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-
-LOCAL_SDK_VERSION := system_current
-
-LOCAL_PROGUARD_ENABLED := disabled
-include $(BUILD_PACKAGE)
diff --git a/tuner/Android.bp b/tuner/Android.bp
index d094c459..81ae2eda 100644
--- a/tuner/Android.bp
+++ b/tuner/Android.bp
@@ -52,4 +52,7 @@ android_library {
"tv-lib-dagger-compiler",
],
min_sdk_version: "23",
+ lint: {
+ baseline_filename: "lint-baseline.xml",
+ },
}
diff --git a/tuner/tests/robotests/Android.bp b/tuner/tests/robotests/Android.bp
new file mode 100644
index 00000000..a1baf651
--- /dev/null
+++ b/tuner/tests/robotests/Android.bp
@@ -0,0 +1,47 @@
+//
+// Copyright (C) 2023 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_robolectric_test {
+ name: "TvTunerRoboTests",
+ srcs: [
+ "javatests/**/*.java",
+ ],
+ java_resource_dirs: ["config"],
+ static_libs: [
+ "tv-lib-dagger",
+ "androidx.test.core",
+ "tv-lib-dagger-android",
+ "tv-test-common",
+ "tv-test-common-robo",
+ "tv-tuner-testing",
+ ],
+ plugins: [
+ "tv-lib-dagger-android-processor",
+ "tv-lib-dagger-compiler",
+ ],
+ instrumentation_for: "LiveTv",
+ test_options: {
+ timeout: 36000,
+ },
+ upstream: true,
+}
diff --git a/tuner/tests/robotests/Android.mk b/tuner/tests/robotests/Android.mk
deleted file mode 100644
index bf2f24c8..00000000
--- a/tuner/tests/robotests/Android.mk
+++ /dev/null
@@ -1,72 +0,0 @@
-#############################################################
-# Tv Robolectric test target. #
-#############################################################
-LOCAL_PATH := $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE := TvTunerRoboTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_CLASS := JAVA_LIBRARIES
-
-LOCAL_SRC_FILES := $(call all-java-files-under, javatests)
-
-LOCAL_JAVA_LIBRARIES := \
- Robolectric_all-target \
- mockito-robolectric-prebuilt \
- robolectric_android-all-stub \
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- tv-lib-dagger
-
-LOCAL_STATIC_ANDROID_LIBRARIES := \
- androidx.test.core \
- tv-lib-dagger-android \
- tv-test-common \
- tv-test-common-robo \
- tv-tuner-testing \
-
-LOCAL_ANNOTATION_PROCESSORS := \
- tv-lib-dagger-android-processor \
- tv-lib-dagger-compiler \
-
-LOCAL_ANNOTATION_PROCESSOR_CLASSES := \
- dagger.internal.codegen.ComponentProcessor,dagger.android.processor.AndroidProcessor
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-
-LOCAL_MODULE_TAGS := optional
-
-include $(BUILD_STATIC_JAVA_LIBRARY)
-
-#############################################################
-# Tv runner target to run the previous target. #
-#############################################################
-include $(CLEAR_VARS)
-LOCAL_MODULE := RunTvTunerRoboTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-BASE_DIR = com/android/tv/tuner
-EXCLUDE_FILES := \
- $(BASE_DIR)/dvb/DvbTunerHalTest.java \
- $(BASE_DIR)/exoplayer/tests/SampleSourceExtractorTest.java \
-
-LOCAL_ROBOTEST_FILES := $(call find-files-in-subdirs,$(LOCAL_PATH)/javatests,*Test.java,.)
-LOCAL_ROBOTEST_FILES := $(filter-out $(EXCLUDE_FILES),$(LOCAL_ROBOTEST_FILES))
-
-LOCAL_JAVA_LIBRARIES := \
- Robolectric_all-target \
- TvTunerRoboTests \
- mockito-robolectric-prebuilt \
- robolectric_android-all-stub \
- tv-lib-truth \
- tv-test-common \
- tv-test-common-robo \
- tv-tuner-testing \
-
-LOCAL_TEST_PACKAGE := LiveTv
-
-LOCAL_ROBOTEST_TIMEOUT := 36000
-
-include external/robolectric-shadows/run_robotests.mk
diff --git a/tuner/tests/robotests/javatests/com/android/tv/tuner/testing/TvTunerRobolectricTestRunner.java b/tuner/tests/robotests/javatests/com/android/tv/tuner/testing/TvTunerRobolectricTestRunner.java
index 89b7510d..ab0955e5 100644
--- a/tuner/tests/robotests/javatests/com/android/tv/tuner/testing/TvTunerRobolectricTestRunner.java
+++ b/tuner/tests/robotests/javatests/com/android/tv/tuner/testing/TvTunerRobolectricTestRunner.java
@@ -44,7 +44,6 @@ public class TvTunerRobolectricTestRunner extends RobolectricTestRunner {
* We are going to create our own custom manifest so that we can add multiple resource paths to
* it.
*/
- @Override
protected AndroidManifest getAppManifest(Config config) {
final String packageName = "com.android.tv.tuner";