aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormorrislin <morrislin@google.com>2023-11-09 14:22:48 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2023-11-09 14:22:48 +0000
commit72ed5b0aa0a7857ef848a08710ae80f1c81b7d08 (patch)
treed81a7b1130fa0604438422f081609887f4cf19c2
parente86c9de8efd245540eefaf18fc6b480bce13756e (diff)
parent1844493ee745cdeccd5d120cbb2609cd4b702705 (diff)
downloadTV-72ed5b0aa0a7857ef848a08710ae80f1c81b7d08.tar.gz
Convert Android.mk of tv-tunner-testing to Android.bp am: 206f12c97d am: 625f41635b am: 1844493ee7
Original change: https://android-review.googlesource.com/c/platform/packages/apps/TV/+/2819300 Change-Id: Id8c09a745d33272f58151cc0637735b4244c13c8 Signed-off-by: Automerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>
-rw-r--r--tuner/tests/testing/Android.bp41
-rw-r--r--tuner/tests/testing/Android.mk30
2 files changed, 41 insertions, 30 deletions
diff --git a/tuner/tests/testing/Android.bp b/tuner/tests/testing/Android.bp
new file mode 100644
index 00000000..ca482263
--- /dev/null
+++ b/tuner/tests/testing/Android.bp
@@ -0,0 +1,41 @@
+// Copyright (C) 2023 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_library {
+ name: "tv-tuner-testing",
+ srcs: [
+ "src/**/*.java",
+ "src/**/I*.aidl",
+ ],
+ static_libs: [
+ "android-support-annotations",
+ "androidx.test.runner",
+ "tv-guava-android-jar",
+ "mockito-robolectric-prebuilt",
+ "tv-lib-truth",
+ "androidx.test.uiautomator_uiautomator",
+ ],
+ libs: ["tv-common", "live-tv-tuner"],
+ sdk_version: "system_current",
+ aidl: {
+ local_include_dirs: ["src"],
+ },
+}
diff --git a/tuner/tests/testing/Android.mk b/tuner/tests/testing/Android.mk
deleted file mode 100644
index 2d800021..00000000
--- a/tuner/tests/testing/Android.mk
+++ /dev/null
@@ -1,30 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-# Include all test java files.
-LOCAL_SRC_FILES := \
- $(call all-java-files-under, src) \
- $(call all-Iaidl-files-under, src)
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- android-support-annotations \
- androidx.test.runner \
- tv-guava-android-jar \
- mockito-robolectric-prebuilt \
- tv-lib-truth \
- androidx.test.uiautomator_uiautomator \
-
-# Link tv-common as shared library to avoid the problem of initialization of the constants
-LOCAL_JAVA_LIBRARIES := tv-common
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-LOCAL_MODULE := tv-tuner-testing
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_TAGS := optional
-LOCAL_SDK_VERSION := system_current
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
-LOCAL_AIDL_INCLUDES += $(LOCAL_PATH)/src
-
-include $(BUILD_STATIC_JAVA_LIBRARY)