aboutsummaryrefslogtreecommitdiff
path: root/common
diff options
context:
space:
mode:
authorNick Chalko <nchalko@google.com>2019-01-23 08:18:14 -0800
committerNick Chalko <nchalko@google.com>2019-01-23 08:30:22 -0800
commit5f030f6bef6fdb0596d8b4e395117f396d471fe1 (patch)
treec9e98887876bb6128944f593c2edb27ebb5e3f52 /common
parentfa78f0656ed55837a68996411aef616e965af65d (diff)
downloadTV-5f030f6bef6fdb0596d8b4e395117f396d471fe1.tar.gz
Migrate tv/common to song
Change-Id: I9db304a3b08c1fdfb3288520efc1f7ebcb557db2 Test: m tv-common Bug: 123237823
Diffstat (limited to 'common')
-rw-r--r--common/Android.bp64
-rw-r--r--common/Android.mk60
2 files changed, 64 insertions, 60 deletions
diff --git a/common/Android.bp b/common/Android.bp
new file mode 100644
index 00000000..cb2f15ae
--- /dev/null
+++ b/common/Android.bp
@@ -0,0 +1,64 @@
+// Copyright (C) 2019 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+android_library {
+ name: "tv-common",
+ srcs: [
+ "src/**/*.java",
+ "src/**/*.proto",
+ ],
+
+ sdk_version: "system_current",
+
+ proto: {
+ type: "lite",
+ },
+
+ resource_dirs: ["res"],
+
+ libs: [
+ "auto-value-jar",
+ "auto-factory-jar",
+ "android-support-annotations",
+ "error-prone-annotations-jar",
+ "guava-android-jar",
+ "jsr330",
+ "lib-dagger",
+ "lib-exoplayer",
+ "lib-exoplayer-v2-core",
+ "android-support-compat",
+ "android-support-core-ui",
+ "android-support-v7-recyclerview",
+ "android-support-v17-leanback",
+ ],
+
+ static_libs: ["lib-dagger-android"],
+
+ annotation_processors: [
+ "auto-value-jar",
+ "auto-factory-jar",
+ "guava-jre-jar",
+ "javawriter-jar",
+ "javax-annotations-jar",
+ "jsr330",
+ ],
+
+ annotation_processor_classes: ["com.google.auto.factory.processor.AutoFactoryProcessor,com.google.auto.value.processor.AutoValueProcessor"],
+
+ min_sdk_version: "23",
+
+ // TODO(b/77284273): generate build config after dagger supports libraries
+ //include $(LOCAL_PATH)/buildconfig.mk
+
+}
diff --git a/common/Android.mk b/common/Android.mk
deleted file mode 100644
index 18c50754..00000000
--- a/common/Android.mk
+++ /dev/null
@@ -1,60 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-# Include all common java files.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-LOCAL_SRC_FILES += $(call all-proto-files-under, src)
-
-LOCAL_MODULE := tv-common
-LOCAL_MODULE_CLASS := STATIC_JAVA_LIBRARIES
-LOCAL_MODULE_TAGS := optional
-LOCAL_SDK_VERSION := system_current
-
-LOCAL_PROTOC_OPTIMIZE_TYPE := lite
-LOCAL_PROTOC_FLAGS := --proto_path=$(LOCAL_PATH)/src/
-
-
-LOCAL_USE_AAPT2 := true
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
-
-LOCAL_JAVA_LIBRARIES := \
- auto-value-jar \
- auto-factory-jar \
- android-support-annotations \
- error-prone-annotations-jar \
- guava-android-jar \
- jsr330 \
- lib-dagger \
- lib-exoplayer \
- lib-exoplayer-v2-core \
-
-
-LOCAL_DISABLE_RESOLVE_SUPPORT_LIBRARIES := true
-
-LOCAL_SHARED_ANDROID_LIBRARIES := \
- android-support-compat \
- android-support-core-ui \
- android-support-v7-recyclerview \
- android-support-v17-leanback \
-
-LOCAL_STATIC_ANDROID_LIBRARIES := \
- lib-dagger-android \
-
-LOCAL_ANNOTATION_PROCESSORS := \
- auto-value-jar \
- auto-factory-jar \
- guava-jre-jar \
- javawriter-jar \
- javax-annotations-jar \
- jsr330 \
-
-LOCAL_ANNOTATION_PROCESSOR_CLASSES := \
- com.google.auto.factory.processor.AutoFactoryProcessor,com.google.auto.value.processor.AutoValueProcessor
-
-LOCAL_MIN_SDK_VERSION := 23
-
-# TODO(b/77284273): generate build config after dagger supports libraries
-#include $(LOCAL_PATH)/buildconfig.mk
-
-include $(BUILD_STATIC_JAVA_LIBRARY)