aboutsummaryrefslogtreecommitdiff
path: root/src/com/android/tv/dvr/ui/browse/DvrHistoryCardPresenter.java
diff options
context:
space:
mode:
authorLive Channels Team <no-reply@google.com>2018-02-16 10:34:47 -0800
committerNick Chalko <nchalko@google.com>2018-02-16 11:50:03 -0800
commit0cc0713c1bf8027642987b750b80217569d2932a (patch)
treeafafc2e82a5626b383e495635c843c51ceb985c5 /src/com/android/tv/dvr/ui/browse/DvrHistoryCardPresenter.java
parentee959c2539b768dd3fbcbdf70acb03e536a9d76d (diff)
downloadTV-0cc0713c1bf8027642987b750b80217569d2932a.tar.gz
Changes imported from Live Channels
- 186014614 Sync more make files with master by nchalko <nchalko@google.com> - 186013553 FIX: safely parse URI from intents. by nchalko <nchalko@google.com> - 186010488 Add missing license header by nchalko <nchalko@google.com> - 186009400 Sync all make files with master by nchalko <nchalko@google.com> - 185891159 Extract a Channel interface by nchalko <nchalko@google.com> - 185885678 Make recording history available by shubang <shubang@google.com> - 185725900 Extract an interface for TunableTvView by nchalko <nchalko@google.com> - 185724604 CLEANUP: Move ImageLoader to a separate package by nchalko <nchalko@google.com> - 185722979 CLEANUP: Fix amiguous method reference by renaming static... by nchalko <nchalko@google.com> - 185721563 CLEANUP: create a seperate top level target for resources by nchalko <nchalko@google.com> - 185720102 CLEANUP: fix comparison using reference equality instead ... by nchalko <nchalko@google.com> - 185717674 CLEANUP: Move MemoryManageable to a separate package by nchalko <nchalko@google.com> - 185609615 FIX: Improve Program Guide description for talkback by nchalko <nchalko@google.com> - 185607602 PARTIAL: Speak the channel number for each item in the pr... by nchalko <nchalko@google.com> - 185552957 CLEANUP: Move TestUtils to tests/common by nchalko <nchalko@google.com> - 185549529 PARTIAL: Add program description to the content discripti... by nchalko <nchalko@google.com> - 185521822 Use robolectric 3.6.1 in android.mk by nchalko <nchalko@google.com> - 185521733 Add recording info to ProgramItemView content description by nchalko <nchalko@google.com> - 185459218 Add time to ProgramItemView content description by nchalko <nchalko@google.com> - 185449505 Add clock to the Utils.getDurationString by nchalko <nchalko@google.com> - 185435931 Inject the clock in ProgramItemView for testing by nchalko <nchalko@google.com> - 185435648 Fix link-type warnings by nchalko <nchalko@google.com> - 185435488 Migrate to AAPT2 by nchalko <nchalko@google.com> - 185434148 Add uptimeMillis to the Clock interface by nchalko <nchalko@google.com> PiperOrigin-RevId: 186014614 Change-Id: I583af9ac3e56161736504024b62d1fd62e31c15a Test: tested in google3
Diffstat (limited to 'src/com/android/tv/dvr/ui/browse/DvrHistoryCardPresenter.java')
-rw-r--r--src/com/android/tv/dvr/ui/browse/DvrHistoryCardPresenter.java64
1 files changed, 64 insertions, 0 deletions
diff --git a/src/com/android/tv/dvr/ui/browse/DvrHistoryCardPresenter.java b/src/com/android/tv/dvr/ui/browse/DvrHistoryCardPresenter.java
new file mode 100644
index 00000000..62c050c9
--- /dev/null
+++ b/src/com/android/tv/dvr/ui/browse/DvrHistoryCardPresenter.java
@@ -0,0 +1,64 @@
+/*
+ * Copyright (C) 2018 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.tv.dvr.ui.browse;
+
+import android.content.Context;
+import android.graphics.drawable.Drawable;
+import android.view.View;
+import com.android.tv.R;
+import com.android.tv.dvr.ui.DvrUiHelper;
+
+/** Presents a DVR history card view in the {@link DvrBrowseFragment}. */
+class DvrHistoryCardPresenter extends DvrItemPresenter<Object> {
+ private final Drawable mIconDrawable;
+ private final String mCardTitleText;
+
+ DvrHistoryCardPresenter(Context context) {
+ super(context);
+ mIconDrawable = mContext.getDrawable(R.drawable.dvr_full_schedule);
+ mCardTitleText = mContext.getString(R.string.dvr_history_card_view_title);
+ }
+
+ @Override
+ public DvrItemViewHolder onCreateDvrItemViewHolder() {
+ return new DvrItemViewHolder(new RecordingCardView(mContext));
+ }
+
+ @Override
+ public void onBindDvrItemViewHolder(DvrItemViewHolder vh, Object o) {
+ final RecordingCardView cardView = (RecordingCardView) vh.view;
+
+ cardView.setTitle(mCardTitleText);
+ cardView.setImage(mIconDrawable);
+ }
+
+ @Override
+ public void onUnbindViewHolder(ViewHolder vh) {
+ ((RecordingCardView) vh.view).reset();
+ super.onUnbindViewHolder(vh);
+ }
+
+ @Override
+ protected View.OnClickListener onCreateOnClickListener() {
+ return new View.OnClickListener() {
+ @Override
+ public void onClick(View view) {
+ DvrUiHelper.startDvrHistoryActivity(mContext);
+ }
+ };
+ }
+}