aboutsummaryrefslogtreecommitdiff
path: root/version.mk
diff options
context:
space:
mode:
authorNick Chalko <nchalko@google.com>2015-12-09 13:48:17 -0800
committerNick Chalko <nchalko@google.com>2015-12-11 15:09:19 -0800
commit1abddd9f6225298066094e20a6c29061b6af4590 (patch)
tree97d701f8681cca9939c86e5e61523775d4c13aea /version.mk
parent7d67089aa1e9aa2123c3cd2f386d7019a1544db1 (diff)
downloadTV-1abddd9f6225298066094e20a6c29061b6af4590.tar.gz
Sync to ub-tv-heroes at 1.08.301
source change id If9b64d7bbc6e8f77b360e502d34e5452775c0402 Change-Id: I4ffe87911cb85e54880d1d918d1b8fb7bb8cfb7d
Diffstat (limited to 'version.mk')
-rw-r--r--version.mk16
1 files changed, 6 insertions, 10 deletions
diff --git a/version.mk b/version.mk
index e4a0e140..3b6223ad 100644
--- a/version.mk
+++ b/version.mk
@@ -48,20 +48,17 @@
base_version_major := 1
# Change this for each branch
-base_version_minor := 07
+base_version_minor := 08
# The date of the first commit checked in to the current branch
-base_version_since := 2015-08-23
-
+base_version_since := 2015-10-12
# code_version_major will overflow at 22
code_version_major := $(shell echo $$(($(base_version_major)+3)))
-git_commit_count := $(shell git --git-dir $(LOCAL_PATH)/.git rev-list --since=$(base_version_since) --no-merges --count HEAD)
-#git_commit_count_usb := $(shell git --git-dir $(LOCAL_PATH)/../UsbTunerTvInput/.git rev-list --since=$(base_version_since) --no-merges --count HEAD)
-#code_version_build := $(shell printf "%03d" $$(($(git_commit_count)+$(git_commit_count_usb))))
-# TODO http://b/22930520 version.mk sometimes goes backwards
-code_version_build=007
-
+git_commit_count := $(shell git --git-dir $(LOCAL_PATH)/.git rev-list --since=$(base_version_since) --all --count HEAD)
+# x86 and arm sometimes don't match.
+#code_version_build := $(shell printf "%03d" $(git_commit_count))
+code_version_build := 301
#####################################################
#####################################################
# Collect automatic version code parameters
@@ -117,6 +114,5 @@ base_version_buildtype :=
base_version_arch :=
base_version_density :=
git_commit_count :=
-git_commit_count_usb :=
git_hash :=
date_string :=