aboutsummaryrefslogtreecommitdiff
path: root/tuner/buildconfig.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tuner/buildconfig.mk')
-rw-r--r--tuner/buildconfig.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/tuner/buildconfig.mk b/tuner/buildconfig.mk
new file mode 100644
index 00000000..cece7f2b
--- /dev/null
+++ b/tuner/buildconfig.mk
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2015 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+# Emulate gradles BuildConfig.java
+
+ifeq "$(TARGET_BUILD_VARIANT)" "eng"
+ BC_DEBUG_STATUS := true
+else ifeq "$(TARGET_BUILD_VARIANT)" "userdebug"
+ BC_DEBUG_STATUS := true
+else
+ BC_DEBUG_STATUS := false
+endif
+
+ifeq "$(TARGET_BUILD_VARIANT)" "eng"
+ BC_ENG_STATUS := true
+else
+ BC_ENG_STATUS := false
+endif
+
+gen := $(local-generated-sources-dir)/$(TARGET_BUILD_VARIANT)/BuildConfig.java
+$(gen): PRIVATE_CUSTOM_TOOL = sed -e \
+ 's/%DEBUG%/$(BC_DEBUG_STATUS)/;s/%ENG%/$(BC_ENG_STATUS)/' \
+ $< > $@
+$(gen) : $(LOCAL_PATH)/BuildConfig.java.in
+ $(transform-generated-source)
+LOCAL_GENERATED_SOURCES += $(gen) \ No newline at end of file