summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:12:41 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 16:12:41 +0000
commit9b98f743f2f23ea072c7c97d806b07fe9d49440f (patch)
treef886faedc08dc6cea5597e2e147733e65458fe08
parente3670e02cced7379ac569e32a3556d7b256add31 (diff)
downloadTerminal-9b98f743f2f23ea072c7c97d806b07fe9d49440f.tar.gz
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I6030d1c8c815fcfe0e3bd048b173eaa1500b617a
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index b0ba92c..dfbcbfc 100644
--- a/Android.mk
+++ b/Android.mk
@@ -14,6 +14,7 @@ LOCAL_JNI_SHARED_LIBRARIES := libjni_terminal
LOCAL_PROGUARD_ENABLED := disabled
LOCAL_PACKAGE_NAME := Terminal
+LOCAL_PRIVATE_PLATFORM_APIS := true
include $(BUILD_PACKAGE)