summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2021-07-15 01:29:38 +0000
committerAndroid Build Coastguard Worker <android-build-coastguard-worker@google.com>2021-07-15 01:29:38 +0000
commitbedc127c5df92bcb52515556c80c93eef93631d3 (patch)
treefc1d9b27fc316702df1d047d29055251d7cea7b7
parentba88d76aa8c1123935bf82afbdaa03e2fdf5d462 (diff)
parent7802874536082218e4e98284f915e3e3ed273216 (diff)
downloadTimeZoneData-android12-mainline-conscrypt-release.tar.gz
Snap for 7550844 from 7802874536082218e4e98284f915e3e3ed273216 to mainline-conscrypt-releaseandroid-mainline-12.0.0_r8android-mainline-12.0.0_r25android12-mainline-conscrypt-release
Change-Id: Iab48ee7202a2cf1ef8b96dd8aab5b095682ca45d
-rw-r--r--Android.bp4
-rw-r--r--OWNERS2
-rw-r--r--oem_template/data_app/build_oem_data_app.mk2
-rw-r--r--oem_template/data_app_prebuilt/include_app_prebuilt.mk2
-rw-r--r--oem_template/xts/Android.mk2
-rw-r--r--src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java2
-rw-r--r--testing/xts/Android.bp4
7 files changed, 16 insertions, 2 deletions
diff --git a/Android.bp b/Android.bp
index fc5a8a9..0ac28da 100644
--- a/Android.bp
+++ b/Android.bp
@@ -13,6 +13,10 @@
// limitations under the License.
// A static library containing all the source needed by a Time Zone Data app.
+package {
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
java_library {
name: "time_zone_distro_provider",
diff --git a/OWNERS b/OWNERS
index e6f6390..c2e58b7 100644
--- a/OWNERS
+++ b/OWNERS
@@ -1,5 +1,5 @@
# Default code reviewers picked from top 3 or more developers.
# Please update this list if you find better candidates.
nfuller@google.com
-peteg@google.com
+dauletz@google.com
vichang@google.com
diff --git a/oem_template/data_app/build_oem_data_app.mk b/oem_template/data_app/build_oem_data_app.mk
index 0c45ff1..0cb2bc0 100644
--- a/oem_template/data_app/build_oem_data_app.mk
+++ b/oem_template/data_app/build_oem_data_app.mk
@@ -38,6 +38,8 @@ LOCAL_SDK_VERSION := system_current
LOCAL_FULL_MANIFEST_FILE := $(OEM_APP_PATH)/AndroidManifest.xml
LOCAL_PACKAGE_NAME := TimeZoneData$(TIME_ZONE_DATA_APP_SUFFIX)
+LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
+LOCAL_LICENSE_CONDITIONS := notice
LOCAL_AAPT_FLAGS := --version-code $(TIME_ZONE_DATA_APP_VERSION_CODE) \
--version-name $(TIME_ZONE_DATA_APP_VERSION_NAME)
diff --git a/oem_template/data_app_prebuilt/include_app_prebuilt.mk b/oem_template/data_app_prebuilt/include_app_prebuilt.mk
index 3ebc464..ec9939a 100644
--- a/oem_template/data_app_prebuilt/include_app_prebuilt.mk
+++ b/oem_template/data_app_prebuilt/include_app_prebuilt.mk
@@ -22,6 +22,8 @@
#
LOCAL_MODULE := TimeZoneDataPrebuilt$(TIME_ZONE_DATA_APP_SUFFIX)
+LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
+LOCAL_LICENSE_CONDITIONS := notice
LOCAL_SRC_FILES := TimeZoneData$(TIME_ZONE_DATA_APP_SUFFIX).apk
LOCAL_OVERRIDES_PACKAGES := TimeZoneData$(TIME_ZONE_DATA_APP_SUFFIX)
LOCAL_MODULE_TAGS := optional
diff --git a/oem_template/xts/Android.mk b/oem_template/xts/Android.mk
index 25be082..d5ceeeb 100644
--- a/oem_template/xts/Android.mk
+++ b/oem_template/xts/Android.mk
@@ -23,6 +23,8 @@ LOCAL_COMPATIBILITY_SUITE := xts
# OEM-INSTRUCTION: OEMs should change this
LOCAL_MODULE := XtsTimeZoneTestCases
+LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
+LOCAL_LICENSE_CONDITIONS := notice
LOCAL_STATIC_JAVA_LIBRARIES := time_zone_data_app_testing
diff --git a/src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java b/src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java
index 0c1b39c..b524fce 100644
--- a/src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java
+++ b/src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java
@@ -103,7 +103,7 @@ public final class TimeZoneRulesDataProvider extends ContentProvider {
+ " instead user=" + currentUserHandle);
}
- // Sanity check our security
+ // Confirm our security
if (!TimeZoneRulesDataContract.AUTHORITY.equals(info.authority)) {
// The authority looked for by the time zone updater is fixed.
throw new SecurityException(
diff --git a/testing/xts/Android.bp b/testing/xts/Android.bp
index 538595b..735a1c5 100644
--- a/testing/xts/Android.bp
+++ b/testing/xts/Android.bp
@@ -16,6 +16,10 @@
// OEMs can include this as a "_STATIC_" dependency and anything else needed to integrate with their
// own test suite. At runtime the libs below (or a superset) must be present.
+package {
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
java_library_host {
name: "time_zone_data_app_testing",
srcs: ["src/**/*.java"],