summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Willemsen <dwillemsen@google.com>2020-01-21 01:08:32 -0800
committerandroid-build-merger <android-build-merger@google.com>2020-01-21 01:08:32 -0800
commit71da9da58bcd6af341c0a75a539c09a6339dec1b (patch)
tree2680528db6d7618d6ac077ed8474a07244e533ec
parent9e491b0f251b306d0a57e5a61168e149e19b395e (diff)
parenta7822da6160016d2f914f60a5e32d6be0b451cda (diff)
downloadTimeZoneData-71da9da58bcd6af341c0a75a539c09a6339dec1b.tar.gz
Convert to Android.bp
am: a7822da616 Change-Id: I843114909576fb9bcd0722f38f454c509acd8e80
-rw-r--r--Android.bp28
-rw-r--r--Android.mk16
-rw-r--r--testing/Android.mk17
-rw-r--r--testing/xts/Android.bp27
-rw-r--r--testing/xts/Android.mk26
5 files changed, 56 insertions, 58 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..fc5a8a9
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,28 @@
+// Copyright (C) 2017 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+// A static library containing all the source needed by a Time Zone Data app.
+java_library {
+ name: "time_zone_distro_provider",
+
+ srcs: ["src/main/**/*.java"],
+ optimize: {
+ proguard_flags_files: ["proguard.cfg"],
+ },
+ static_libs: [
+ "time_zone_distro_unbundled",
+ "androidx.annotation_annotation",
+ ],
+ sdk_version: "system_current",
+}
diff --git a/Android.mk b/Android.mk
index 593db19..4c33620 100644
--- a/Android.mk
+++ b/Android.mk
@@ -12,18 +12,4 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-
-LOCAL_PATH:= $(call my-dir)
-
-# A static library containing all the source needed by a Time Zone Data app.
-include $(CLEAR_VARS)
-LOCAL_MODULE_TAGS := optional
-LOCAL_MODULE := time_zone_distro_provider
-LOCAL_MODULE_TAGS := optional
-LOCAL_SRC_FILES := $(call all-java-files-under, src/main)
-LOCAL_PROGUARD_FLAG_FILES := $(LOCAL_PATH)/proguard.cfg
-LOCAL_STATIC_JAVA_LIBRARIES := time_zone_distro_unbundled androidx.annotation_annotation
-LOCAL_SDK_VERSION := system_current
-include $(BUILD_STATIC_JAVA_LIBRARY)
-
-include $(call all-makefiles-under,$(LOCAL_PATH))
+# Intentionally left empty to hide oem_template/*/Android.mk
diff --git a/testing/Android.mk b/testing/Android.mk
deleted file mode 100644
index 10ee7a0..0000000
--- a/testing/Android.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright (C) 2017 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH:= $(call my-dir)
-
-include $(call all-makefiles-under,$(LOCAL_PATH)) \ No newline at end of file
diff --git a/testing/xts/Android.bp b/testing/xts/Android.bp
new file mode 100644
index 0000000..538595b
--- /dev/null
+++ b/testing/xts/Android.bp
@@ -0,0 +1,27 @@
+// Copyright (C) 2017 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+// A testing support library for testing time zone updates on real devices.
+// OEMs can include this as a "_STATIC_" dependency and anything else needed to integrate with their
+// own test suite. At runtime the libs below (or a superset) must be present.
+
+java_library_host {
+ name: "time_zone_data_app_testing",
+ srcs: ["src/**/*.java"],
+ libs: [
+ "cts-tradefed",
+ "tradefed",
+ "compatibility-host-util",
+ ],
+}
diff --git a/testing/xts/Android.mk b/testing/xts/Android.mk
deleted file mode 100644
index 93bf5e7..0000000
--- a/testing/xts/Android.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright (C) 2017 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH:= $(call my-dir)
-
-# A testing support library for testing time zone updates on real devices.
-# OEMs can include this as a "_STATIC_" dependency and anything else needed to integrate with their
-# own test suite. At runtime the LOCAL_JAVA_LIBRARIES below (or a superset) must be present.
-
-include $(CLEAR_VARS)
-LOCAL_MODULE_TAGS := optional
-LOCAL_MODULE := time_zone_data_app_testing
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-LOCAL_JAVA_LIBRARIES := cts-tradefed tradefed compatibility-host-util
-include $(BUILD_HOST_JAVA_LIBRARY)