aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandroid-build-prod (mdb) <android-build-team-robot@google.com>2018-05-05 14:28:47 -0700
committerandroid-build-merger <android-build-merger@google.com>2018-05-05 14:28:47 -0700
commitcc65565e6f552dcbb8f858f8ffab78d781e689a9 (patch)
tree64af3838be8f1b24b60ba12aa6a0d6dc2d5a37d2
parent9fdd32e6758bcca54518b82a6876e7cd6934cd90 (diff)
parent8f2b472ae1b1914335e3834242c33c26d1d76cad (diff)
downloadexperimental-cc65565e6f552dcbb8f858f8ffab78d781e689a9.tar.gz
Merge "Convert to Soong"
am: 8f2b472ae1 Change-Id: I97a2917d8f1ea9c868ce7bf88223e6f4aad8bd3f
-rw-r--r--procstatlog/Android.bp22
-rw-r--r--procstatlog/Android.mk27
2 files changed, 22 insertions, 27 deletions
diff --git a/procstatlog/Android.bp b/procstatlog/Android.bp
new file mode 100644
index 0000000..f1de6f5
--- /dev/null
+++ b/procstatlog/Android.bp
@@ -0,0 +1,22 @@
+// Copyright (C) 2010 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+// Build a static binary for maximum portability
+// (we want to run this on oddball partner-integrated devices).
+
+cc_binary {
+ name: "procstatlog",
+ static_executable: true,
+ srcs: ["procstatlog.c"],
+}
diff --git a/procstatlog/Android.mk b/procstatlog/Android.mk
deleted file mode 100644
index a2ea669..0000000
--- a/procstatlog/Android.mk
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright (C) 2010 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH := $(call my-dir)
-
-# Build a static binary for maximum portability
-# (we want to run this on oddball partner-integrated devices).
-
-include $(CLEAR_VARS)
-LOCAL_FORCE_STATIC_EXECUTABLE := true
-LOCAL_MODULE := procstatlog
-LOCAL_MODULE_PATH := $(TARGET_OUT_OPTIONAL_EXECUTABLES)
-LOCAL_SRC_FILES := procstatlog.c
-LOCAL_STATIC_LIBRARIES := libc
-
-include $(BUILD_EXECUTABLE)