aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernhard Rosenkraenzer <Bernhard.Rosenkranzer@linaro.org>2011-12-13 21:49:49 +0059
committerBernhard Rosenkraenzer <Bernhard.Rosenkranzer@linaro.org>2011-12-13 21:49:49 +0059
commit90ce8448feaa22552b71d004bf1d88b01e2ab7aa (patch)
treedf54e47020f2cd126785bc60e9c83833c6cd9aa5
parent5a7493236fe08b352f8b975e841de4c5357caa08 (diff)
downloadOpenWnn-linaro_android_4.0.1.tar.gz
libwnnDictionary: Use -fno-strict-aliasinglinaro_android_4.0.1
libwnnDictionary can't be built w/ enforcing of strict aliasing rules without major changes. Turn strict aliasing off here so we don't need to disable it globally. Signed-off-by: Bernhard Rosenkraenzer <Bernhard.Rosenkranzer@linaro.org>
-rw-r--r--libs/libwnnDictionary/Android.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/libs/libwnnDictionary/Android.mk b/libs/libwnnDictionary/Android.mk
index e14069f..0de6cd1 100644
--- a/libs/libwnnDictionary/Android.mk
+++ b/libs/libwnnDictionary/Android.mk
@@ -27,8 +27,14 @@ LOCAL_C_INCLUDES += \
$(JNI_H_INCLUDE) \
$(LOCAL_PATH)/include $(LOCAL_PATH)
+# libwnnDictionary can't be built without optimizations, so we enforce -O if no
+# other optimization flag is set - but we don't override what the global
+# flags are saying if something else is given (-Os or -O3 are useful)
+ifeq ($(findstring -O, $(TARGET_GLOBAL_CFLAGS)),)
LOCAL_CFLAGS += \
-O
+endif
+LOCAL_CFLAGS += -fno-strict-aliasing