summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShixin Zeng <zeng.shixin@gmail.com>2012-02-21 02:10:58 +0100
committerShixin Zeng <zeng.shixin@gmail.com>2012-02-21 02:10:58 +0100
commit7ae6a22c025e3e4588faefe73824bf75e10c3e02 (patch)
tree92302114b617fa3584f388be4b8ebef58583ec01
parent9b32b99cbe494373b3d4ecd8976c9a4e385d745b (diff)
downloadPinyinIME-7ae6a22c025e3e4588faefe73824bf75e10c3e02.tar.gz
provent nativeImOpenDecoder from being removed by proguard
Because it's not been used anywhere, it could be removed by proguard, and that causes the libjni_pinyinime.so fail to be loaded.
-rw-r--r--Android.mk2
-rw-r--r--proguard.cfg3
2 files changed, 5 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 99ad14d..35ff61c 100644
--- a/Android.mk
+++ b/Android.mk
@@ -15,6 +15,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := com.android.inputmethod.pinyin.lib
LOCAL_CERTIFICATE := shared
+LOCAL_PROGUARD_FLAG_FILES := proguard.cfg
+
# Make sure our dictionary file is not compressed, so we can read it with
# a raw file descriptor.
LOCAL_AAPT_FLAGS := -0 .dat
diff --git a/proguard.cfg b/proguard.cfg
new file mode 100644
index 0000000..c7ef519
--- /dev/null
+++ b/proguard.cfg
@@ -0,0 +1,3 @@
+-keep class com.android.inputmethod.pinyin.PinyinDecoderService{
+ native static boolean nativeImOpenDecoder(byte[], byte[]);
+}