summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Android.mk3
-rw-r--r--proguard.flags3
2 files changed, 6 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index d390749..6512720 100644
--- a/Android.mk
+++ b/Android.mk
@@ -22,6 +22,9 @@ LOCAL_PROGUARD_FLAG_FILES := proguard.cfg
# Make sure our dictionary file is not compressed, so we can read it with
# a raw file descriptor.
LOCAL_AAPT_FLAGS := -0 .dat
+LOCAL_AAPT_FLAGS += -0 .dict
+
+LOCAL_PROGUARD_FLAG_FILES := proguard.flags
include $(BUILD_PACKAGE)
diff --git a/proguard.flags b/proguard.flags
new file mode 100644
index 0000000..2888038
--- /dev/null
+++ b/proguard.flags
@@ -0,0 +1,3 @@
+-keep class com.android.inputmethod.pinyin.PinyinDecoderService {
+ *;
+}