summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 18:06:59 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 18:06:59 +0000
commit05bdfb1ef1792bb116e07b630d5eb9f773c80034 (patch)
tree4f0c569e3e6a47cda3aa3a10dfceb7fb68668dfe
parent15af0ce0d0cef924e73214857d8f7011ad586772 (diff)
downloadBookmarkProvider-05bdfb1ef1792bb116e07b630d5eb9f773c80034.tar.gz
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: Iff8a6ea6f7fce799cdb5b6768bf64be776bd2530
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 16d0c18..f2100b5 100644
--- a/Android.mk
+++ b/Android.mk
@@ -22,6 +22,7 @@ LOCAL_SRC_FILES := \
$(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := BookmarkProvider
+LOCAL_PRIVATE_PLATFORM_APIS := true
include $(BUILD_PACKAGE)