summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-08 16:07:44 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-08 16:07:44 -0800
commit888d5829751547ddb1df2f81f5269e1b9b12b851 (patch)
treeb29fe046577f2c9fca0db332417f538f383e2d5e
parentf9cd6cd84cdf51b44b8565e6115dd9304aa5680a (diff)
parentd0ec84c79bddd73ca7a66c68a278b7afdb2024bd (diff)
downloadBookmarkProvider-888d5829751547ddb1df2f81f5269e1b9b12b851.tar.gz
Convert Android.mk file to Android.bp. am: a584e14ad8 am: 686a5e5e35
am: d0ec84c79b Change-Id: I2554a7ca87686a61767be89e7f1af06bf45095ee
-rw-r--r--Android.bp19
-rw-r--r--Android.mk28
2 files changed, 19 insertions, 28 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..0f73493
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,19 @@
+// Copyright (C) 2019 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License"); you may not
+// use this file except in compliance with the License. You may obtain a copy of
+// the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+// WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+// License for the specific language governing permissions and limitations under
+// the License.
+
+android_app {
+ name: "BookmarkProvider",
+ srcs: ["src/**/*.java"],
+ platform_apis: true,
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index f2100b5..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright (C) 2015 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License"); you may not
-# use this file except in compliance with the License. You may obtain a copy of
-# the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
-# License for the specific language governing permissions and limitations under
-# the License.
-
-LOCAL_PATH:= $(call my-dir)
-
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_SRC_FILES := \
- $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := BookmarkProvider
-LOCAL_PRIVATE_PLATFORM_APIS := true
-
-include $(BUILD_PACKAGE)
-