aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-01-17 14:49:43 +0000
committerPaul Duffin <paulduffin@google.com>2017-01-18 15:29:06 +0000
commit7efaa4cedd5631f80b9b90a0aee4d091058581c0 (patch)
tree44dfc7fb2a84f08c1948ff9af7187592af8d806e /tests
parent9ce8290df035fa24263164435ecfd01f2505f328 (diff)
downloadContactsProvider-7efaa4cedd5631f80b9b90a0aee4d091058581c0.tar.gz
Prepare for removal of legacy-test from default targets
In preparation for removing junit classes from the Android API the legacy-test target will be removed from the TARGET_DEFAULT_JAVA_LIBRARIES. This change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. (cherry picked from b7099adc38fd3760f96721e9b3a768e4a5068c97) Bug: 30188076 Test: make checkbuild Merged-In: I1cc80298ffd6402b91227d45f86fd958d589da50 Change-Id: If1c1df5f5132f2d90d3fd932f28425fec505c6d5
Diffstat (limited to 'tests')
-rw-r--r--tests/Android.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index 35a6b395..f2e0fc1a 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -4,7 +4,7 @@ include $(CLEAR_VARS)
# We only want this apk build for tests.
LOCAL_MODULE_TAGS := tests
-LOCAL_STATIC_JAVA_LIBRARIES := mockito-target
+LOCAL_STATIC_JAVA_LIBRARIES := mockito-target legacy-android-test
LOCAL_JAVA_LIBRARIES := android.test.runner