summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWink Saville <wink@google.com>2012-06-14 12:40:20 -0700
committerWink Saville <wink@google.com>2012-06-14 12:40:20 -0700
commit917cf0fdd6d45ce901e63c54eb100920daeb89bf (patch)
tree496f1879f7a9a9f10ef5841d542b1f2b794e77c9
parentdb356aa3972dbd4ba60e9cc4758813c0f1d1c92e (diff)
downloadDrmProvider-917cf0fdd6d45ce901e63c54eb100920daeb89bf.tar.gz
Use telephony-common
Change-Id: I5d259639d8bb5e5c4573941bb8ea93aa4bcad082
-rw-r--r--Android.mk2
-rw-r--r--src/com/android/providers/drm/DrmPushReceiver.java4
2 files changed, 3 insertions, 3 deletions
diff --git a/Android.mk b/Android.mk
index 6ee75f0..66989db 100644
--- a/Android.mk
+++ b/Android.mk
@@ -5,7 +5,7 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-subdir-java-files)
-LOCAL_JAVA_LIBRARIES :=
+LOCAL_JAVA_LIBRARIES := telephony-common
LOCAL_PACKAGE_NAME := DrmProvider
LOCAL_CERTIFICATE := media
diff --git a/src/com/android/providers/drm/DrmPushReceiver.java b/src/com/android/providers/drm/DrmPushReceiver.java
index abe5ca0..4922330 100644
--- a/src/com/android/providers/drm/DrmPushReceiver.java
+++ b/src/com/android/providers/drm/DrmPushReceiver.java
@@ -22,11 +22,11 @@ import java.io.IOException;
import android.drm.mobile1.DrmException;
import android.drm.mobile1.DrmRights;
import android.drm.mobile1.DrmRightsManager;
-import static android.provider.Telephony.Sms.Intents.WAP_PUSH_RECEIVED_ACTION;
import android.content.Context;
import android.content.Intent;
import android.content.BroadcastReceiver;
+import android.provider.Telephony;
import android.util.Log;
public class DrmPushReceiver extends BroadcastReceiver {
@@ -34,7 +34,7 @@ public class DrmPushReceiver extends BroadcastReceiver {
@Override
public void onReceive(Context context, Intent intent) {
- if (intent.getAction().equals(WAP_PUSH_RECEIVED_ACTION)) {
+ if (intent.getAction().equals(Telephony.Sms.Intents.WAP_PUSH_RECEIVED_ACTION)) {
// Get right mimetype.
String rightMimeType = intent.getType();
if (DrmRightsManager.DRM_MIMETYPE_RIGHTS_XML_STRING.equals(rightMimeType) ||