summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThe Android Open Source Project <initial-contribution@android.com>2009-03-03 14:04:38 -0800
committerThe Android Open Source Project <initial-contribution@android.com>2009-03-03 14:04:38 -0800
commit6d84f351b52bcfea4577c26cc5305c14fe873e9c (patch)
treece032be5cbb0bc9d58ad8e9325007c33b8e3f5f8
parent571f6b2cabdc9ece4f9ec7e09b82c12d1940805c (diff)
downloadGoogleSubscribedFeedsProvider-6d84f351b52bcfea4577c26cc5305c14fe873e9c.tar.gz
auto import from //depot/cupcake/@132589
-rw-r--r--Android.mk3
-rw-r--r--AndroidManifest.xml14
-rw-r--r--res/values-cs/strings.xml41
-rw-r--r--res/values-de/strings.xml41
-rw-r--r--res/values-es/strings.xml41
-rw-r--r--res/values-fr/strings.xml41
-rw-r--r--res/values-it/strings.xml41
-rw-r--r--res/values-ja/strings.xml41
-rw-r--r--res/values-ko/strings.xml41
-rw-r--r--res/values-nl/strings.xml41
-rw-r--r--res/values-pl/strings.xml41
-rw-r--r--res/values-ru/strings.xml41
-rw-r--r--res/values-zh-rCN/strings.xml41
-rw-r--r--res/values-zh-rTW/strings.xml41
-rw-r--r--src/com/android/providers/subscribedfeeds/SubscribedFeedsSyncAdapter.java2
15 files changed, 9 insertions, 502 deletions
diff --git a/Android.mk b/Android.mk
index 510f50c..5e01e84 100644
--- a/Android.mk
+++ b/Android.mk
@@ -5,8 +5,7 @@ LOCAL_MODULE_TAGS := user
base_packages := ../../../frameworks/base/packages
source_files := $(base_packages)/SubscribedFeedsProvider/src/com/android/providers/subscribedfeeds/SubscribedFeedsProvider.java
-source_files += $(base_packages)/SubscribedFeedsProvider/src/com/android/providers/subscribedfeeds/SubscribedFeedsIntentService.java
-source_files += $(base_packages)/SubscribedFeedsProvider/src/com/android/providers/subscribedfeeds/SubscribedFeedsBroadcastReceiver.java
+source_files += $(base_packages)/SubscribedFeedsProvider/src/com/android/providers/subscribedfeeds/SubscribedFeedsService.java
LOCAL_SRC_FILES := $(call all-subdir-java-files) $(source_files)
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index f3c8ee9..41aa9fe 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -12,14 +12,14 @@
<uses-permission android:name="android.permission.READ_SYNC_STATS" />
<uses-permission android:name="android.permission.SUBSCRIBED_FEEDS_READ" />
<uses-permission android:name="android.permission.SUBSCRIBED_FEEDS_WRITE" />
-
+
<application android:process="system"
android:allowClearUserData="false"
android:icon="@drawable/app_icon"
android:label="Sync Feeds">
-
+
<uses-library android:name="com.google.android.gtalkservice" />
-
+
<activity android:name="com.android.settings.SyncSettings" android:label="@string/sync_settings">
<intent-filter>
<action android:name="android.intent.action.MAIN" />
@@ -36,14 +36,14 @@
<category android:name="android.intent.category.DEFAULT" />
</intent-filter>
</activity>
-
+
<provider android:name="GoogleSubscribedFeedsProvider"
android:authorities="subscribedfeeds" android:syncable="true"
android:multiprocess="false"
android:readPermission="android.permission.SUBSCRIBED_FEEDS_READ"
android:writePermission="android.permission.SUBSCRIBED_FEEDS_WRITE" />
-
- <receiver android:name="SubscribedFeedsBroadcastReceiver">
+
+ <receiver android:name="SubscribedFeedsService">
<intent-filter>
<action android:name="android.intent.action.GTALK_DATA_MESSAGE_RECEIVED" />
<category android:name="GSYNC_TICKLE"/>
@@ -55,6 +55,6 @@
<action android:name="com.android.subscribedfeeds.action.REFRESH" />
</intent-filter>
</receiver>
- <service android:name="SubscribedFeedsIntentService"/>
+
</application>
</manifest>
diff --git a/res/values-cs/strings.xml b/res/values-cs/strings.xml
deleted file mode 100644
index e4ab154..0000000
--- a/res/values-cs/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"Synchronizace dat"</string>
- <string name="sync_too_many_deletes">"Byl překročen limit mazání."</string>
- <string name="background_data">"Data na pozadí"</string>
- <string name="background_data_summary">"Povolit používání dat na pozadí"</string>
- <string name="background_data_dialog_title">"Upozornění"</string>
- <string name="background_data_dialog_message">"Zakázání dat na pozadí šetří baterii a snižuje objem použitých dat. Některé aplikace mohou přesto datové připojení na pozadí používat."</string>
- <string name="sync_automatically">"Automatická synchronizace"</string>
- <string name="sync_automatically_summary">"Data jsou synchronizována automaticky"</string>
- <string name="sync_menu_sync_now">"Synchronizovat nyní"</string>
- <string name="sync_menu_sync_cancel">"Zrušit synchronizaci"</string>
- <string name="sync_one_time_sync">"Synchronizovat nyní<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"Kalendář"</string>
- <string name="sync_contacts">"Kontakty"</string>
- <string name="sync_too_many_deletes_desc">"Počet smazaných položek: <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g>, typ synchronizace: <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>, účet: <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>. Jakou akci chcete provést?"</string>
- <string name="sync_really_delete">"Smazat položky."</string>
- <string name="sync_undo_deletes">"Vrátit mazání zpět."</string>
- <string name="sync_do_nothing">"Nyní neprovádět žádnou akci."</string>
- <string name="sync_is_failing">"Nastaly potíže se synchronizací. Služba bude brzy obnovena."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Vítá vás aplikace Google Sync"</font>" "\n"Nový pohled na synchronizaci dat v režii Google. Poskytuje vám přístup ke kontaktům, schůzkám a dalším náležitostem, ať jste kdekoli."</string>
- <string name="header_application_sync_settings">"Nastavení synchronizace aplikace"</string>
- <string name="header_general_sync_settings">"Obecná nastavení synchronizace"</string>
-</resources>
diff --git a/res/values-de/strings.xml b/res/values-de/strings.xml
deleted file mode 100644
index a952b11..0000000
--- a/res/values-de/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"Datensynchronisierung"</string>
- <string name="sync_too_many_deletes">"Löschbegrenzung überschritten"</string>
- <string name="background_data">"Hintergrunddaten"</string>
- <string name="background_data_summary">"Verwendung von Hintergrunddaten aktivieren"</string>
- <string name="background_data_dialog_title">"Achtung"</string>
- <string name="background_data_dialog_message">"Durch die Deaktivierung von Hintergrunddaten kann Strom gespart und die Verwendung von Daten verringert werden. Einige Anwendungen nutzen die Hintergrunddatenverbindung möglicherweise weiterhin."</string>
- <string name="sync_automatically">"Autom. Synchronisierung"</string>
- <string name="sync_automatically_summary">"Daten automatisch synchronisieren"</string>
- <string name="sync_menu_sync_now">"Jetzt synchronisieren"</string>
- <string name="sync_menu_sync_cancel">"Synchronisierung abbrechen"</string>
- <string name="sync_one_time_sync">"Jetzt synchronisieren: <xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"Google Kalender"</string>
- <string name="sync_contacts">"Kontakte"</string>
- <string name="sync_too_many_deletes_desc">"Für <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>, Konto <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>, liegen <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g> gelöschte Elemente vor. Was möchten Sie tun?"</string>
- <string name="sync_really_delete">"Elemente löschen"</string>
- <string name="sync_undo_deletes">"Löschen rückgängig machen"</string>
- <string name="sync_do_nothing">"Im Moment nichts unternehmen"</string>
- <string name="sync_is_failing">"Bei der Synchronisierung treten derzeit Probleme auf. Sie wird in Kürze fortgesetzt."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Willkommen bei Google Sync!"</font>\n"Mit dieser Funktion von Google können Sie Ihre Daten synchronisieren, um auf Ihre Kontakte, Termine und vieles mehr zuzugreifen - wo immer Sie auch sind!"</string>
- <string name="header_application_sync_settings">"Einstellungen für die Anwendungssynchronisierung"</string>
- <string name="header_general_sync_settings">"Allgemeine Synchronisierungseinstellungen"</string>
-</resources>
diff --git a/res/values-es/strings.xml b/res/values-es/strings.xml
deleted file mode 100644
index c1298a7..0000000
--- a/res/values-es/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"Sincronización de datos"</string>
- <string name="sync_too_many_deletes">"Límite de eliminaciones superado"</string>
- <string name="background_data">"Datos de referencia"</string>
- <string name="background_data_summary">"Habilitar el uso de datos de referencia"</string>
- <string name="background_data_dialog_title">"Atención"</string>
- <string name="background_data_dialog_message">"Si inhabilitas los datos de referencia, ahorrarás batería y reducirás el uso de datos. Es posible que algunas aplicaciones sigan utilizando la conexión de datos de referencia."</string>
- <string name="sync_automatically">"Sincronización automática"</string>
- <string name="sync_automatically_summary">"Sincronizar datos de forma automática"</string>
- <string name="sync_menu_sync_now">"Sincronizar ahora"</string>
- <string name="sync_menu_sync_cancel">"Cancelar sincronización"</string>
- <string name="sync_one_time_sync">"Seleccionar para realizar la sincronización ahora<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"Calendar"</string>
- <string name="sync_contacts">"Contactos"</string>
- <string name="sync_too_many_deletes_desc">"Hay <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g> elementos eliminados para <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>, cuenta <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>. ¿Qué quieres hacer?"</string>
- <string name="sync_really_delete">"Eliminar los elementos"</string>
- <string name="sync_undo_deletes">"Deshacer las eliminaciones"</string>
- <string name="sync_do_nothing">"No hacer nada por ahora"</string>
- <string name="sync_is_failing">"En este momento hay problemas con la sincronización. Se restablecerá en breve."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Te damos la bienvenida a Google Sync."</font>" "\n"Un servicio de Google para sincronizar datos y permitir así el acceso a tus contactos, citas, etc. desde cualquier ubicación."</string>
- <string name="header_application_sync_settings">"Configuración de sincronización de aplicación"</string>
- <string name="header_general_sync_settings">"Configuración de sincronización general"</string>
-</resources>
diff --git a/res/values-fr/strings.xml b/res/values-fr/strings.xml
deleted file mode 100644
index f2c9748..0000000
--- a/res/values-fr/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"Synchronisation"</string>
- <string name="sync_too_many_deletes">"Le nombre maximum de suppressions a été atteint."</string>
- <string name="background_data">"Données en arrière-plan"</string>
- <string name="background_data_summary">"Activer l\'utilisation des données en arrière-plan"</string>
- <string name="background_data_dialog_title">"Attention"</string>
- <string name="background_data_dialog_message">"La désactivation des données en arrière-plan permet d\'économiser la batterie et de réduire l\'utilisation des données. Certaines applications peuvent utiliser la connexion des données en arrière-plan."</string>
- <string name="sync_automatically">"Synchronisation auto"</string>
- <string name="sync_automatically_summary">"Synchronisation automatique des données"</string>
- <string name="sync_menu_sync_now">"Synchroniser maintenant"</string>
- <string name="sync_menu_sync_cancel">"Annuler la synchronisation"</string>
- <string name="sync_one_time_sync">"Synchroniser maintenant <xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"Google Agenda"</string>
- <string name="sync_contacts">"Contacts"</string>
- <string name="sync_too_many_deletes_desc">"Il y a <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g> éléments supprimés pour <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>, pour le compte <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>. Que souhaitez-vous faire ?"</string>
- <string name="sync_really_delete">"Supprimer les éléments"</string>
- <string name="sync_undo_deletes">"Annuler les suppressions"</string>
- <string name="sync_do_nothing">"Ne rien faire pour l\'instant"</string>
- <string name="sync_is_failing">"La synchronisation rencontre actuellement des problèmes. Elle sera rétablie sous peu."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Bienvenue sur Google Sync !"</font>" "\n"Une approche Google pour synchroniser vos données afin de vous permettre l\'accès à vos contacts, rendez-vous et plus encore, où que vous vous trouviez."</string>
- <string name="header_application_sync_settings">"Synchronisation de l\'application"</string>
- <string name="header_general_sync_settings">"Paramètres généraux"</string>
-</resources>
diff --git a/res/values-it/strings.xml b/res/values-it/strings.xml
deleted file mode 100644
index 8e21338..0000000
--- a/res/values-it/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"Sincronizzazione dati"</string>
- <string name="sync_too_many_deletes">"Limite di eliminazioni superato"</string>
- <string name="background_data">"Dati in background"</string>
- <string name="background_data_summary">"Attiva utilizzo dei dati in background"</string>
- <string name="background_data_dialog_title">"Attenzione"</string>
- <string name="background_data_dialog_message">"La disattivazione dei dati in background consente di ridurre il consumo delle batterie e l\'utilizzo dei dati. Alcune applicazioni potrebbero utilizzare comunque la connessione dati in background."</string>
- <string name="sync_automatically">"Sincronizzazione automatica"</string>
- <string name="sync_automatically_summary">"Sincronizza i dati automaticamente"</string>
- <string name="sync_menu_sync_now">"Sincronizza ora"</string>
- <string name="sync_menu_sync_cancel">"Annulla sincronizzazione"</string>
- <string name="sync_one_time_sync">"Seleziona per sincronizzare ora<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"Calendario"</string>
- <string name="sync_contacts">"Contatti"</string>
- <string name="sync_too_many_deletes_desc">"Esistono <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g> elementi eliminati per <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>, account <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>. Specifica l\'operazione da eseguire."</string>
- <string name="sync_really_delete">"Elimina gli elementi."</string>
- <string name="sync_undo_deletes">"Annulla le eliminazioni."</string>
- <string name="sync_do_nothing">"Non fare nulla per ora."</string>
- <string name="sync_is_failing">"La sincronizzazione presenta dei problemi. L\'operazione verrà ripristinata a breve."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Benvenuto in Google Sync."</font>" "\n"L\'approccio di Google alla sincronizzazione di dati per consentirti l\'accesso ai tuoi contatti, appuntamenti e altro ancora, dovunque tu sia."</string>
- <string name="header_application_sync_settings">"Impostazioni sincronizzazione applicazioni"</string>
- <string name="header_general_sync_settings">"Impostazioni generali di sincronizzazione"</string>
-</resources>
diff --git a/res/values-ja/strings.xml b/res/values-ja/strings.xml
deleted file mode 100644
index bc69151..0000000
--- a/res/values-ja/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"データの同期化"</string>
- <string name="sync_too_many_deletes">"削除の制限を超えました"</string>
- <string name="background_data">"バックグラウンドデータ"</string>
- <string name="background_data_summary">"バックグラウンドデータの使用を有効にする"</string>
- <string name="background_data_dialog_title">"注意"</string>
- <string name="background_data_dialog_message">"バックグラウンドデータを無効にすると、データの使用が減るため電池を節約できます。一部のアプリケーションでは引き続きバックグラウンドデータの接続を使用します。"</string>
- <string name="sync_automatically">"自動同期"</string>
- <string name="sync_automatically_summary">"自動的にデータを同期"</string>
- <string name="sync_menu_sync_now">"今すぐ同期"</string>
- <string name="sync_menu_sync_cancel">"同期をキャンセル"</string>
- <string name="sync_one_time_sync">"今すぐ同期を選択<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"カレンダー"</string>
- <string name="sync_contacts">"連絡先"</string>
- <string name="sync_too_many_deletes_desc">"アカウント「<xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>」で<xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>の<xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g>個の項目が削除されています。処理を選択してください。"</string>
- <string name="sync_really_delete">"項目を削除します。"</string>
- <string name="sync_undo_deletes">"削除を元に戻します。"</string>
- <string name="sync_do_nothing">"今は何もしません。"</string>
- <string name="sync_is_failing">"現在同期で問題が発生しています。しばらくお待ちください。"</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Google Syncへようこそ"</font>" "\n"このサービスを使用すると、データを同期してどこからでも連絡先や予定などにアクセスできます。"</string>
- <string name="header_application_sync_settings">"アプリケーションの同期設定"</string>
- <string name="header_general_sync_settings">"同期の全般設定"</string>
-</resources>
diff --git a/res/values-ko/strings.xml b/res/values-ko/strings.xml
deleted file mode 100644
index 4b49473..0000000
--- a/res/values-ko/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"데이터 동기화"</string>
- <string name="sync_too_many_deletes">"삭제 한도를 초과했습니다."</string>
- <string name="background_data">"배경 데이터"</string>
- <string name="background_data_summary">"배경 데이터 사용 설정"</string>
- <string name="background_data_dialog_title">"주의"</string>
- <string name="background_data_dialog_message">"배경 데이터를 사용하지 않도록 설정하면 배터리가 절약되고 데이터 사용률이 낮아집니다. 일부 응용프로그램은 여전히 배경 데이터 연결을 사용할 수 있습니다."</string>
- <string name="sync_automatically">"자동 동기화"</string>
- <string name="sync_automatically_summary">"자동으로 데이터 동기화"</string>
- <string name="sync_menu_sync_now">"지금 동기화"</string>
- <string name="sync_menu_sync_cancel">"동기화 취소"</string>
- <string name="sync_one_time_sync">"지금 동기화하도록 선택(<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>)"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"캘린더"</string>
- <string name="sync_contacts">"주소록"</string>
- <string name="sync_too_many_deletes_desc">"<xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>, <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g> 계정에 대해 <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g>개의 삭제된 항목이 있습니다. 어떻게 하시겠습니까?"</string>
- <string name="sync_really_delete">"항목 삭제"</string>
- <string name="sync_undo_deletes">"삭제 실행취소"</string>
- <string name="sync_do_nothing">"지금은 아무 작업도 안함"</string>
- <string name="sync_is_failing">"동기화에 현재 문제가 발생했습니다. 곧 다시 동기화됩니다."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Google 동기화를 시작합니다."</font>" "\n"사용자가 어디에서든지 주소록, 일정 등에 액세스할 수 있도록 데이터를 동기화하는 방법입니다."</string>
- <string name="header_application_sync_settings">"응용프로그램 동기화 설정"</string>
- <string name="header_general_sync_settings">"기본 동기화 설정"</string>
-</resources>
diff --git a/res/values-nl/strings.xml b/res/values-nl/strings.xml
deleted file mode 100644
index 091eed9..0000000
--- a/res/values-nl/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"Gegevenssynchronisatie"</string>
- <string name="sync_too_many_deletes">"Verwijderingslimiet overschreden"</string>
- <string name="background_data">"Achtergrondgegevens"</string>
- <string name="background_data_summary">"Gebruik van achtergrondgegevens inschakelen"</string>
- <string name="background_data_dialog_title">"Let op"</string>
- <string name="background_data_dialog_message">"Als u achtergrondgegevens uitschakelt, bespaart u batterijlading en wordt het gegevensverbruik verlaagd. Sommige toepassingen maken mogelijk nog steeds gebruik van de achtergrondgegevensverbinding."</string>
- <string name="sync_automatically">"Automatische synchronisatie"</string>
- <string name="sync_automatically_summary">"Gegevens automatisch synchroniseren"</string>
- <string name="sync_menu_sync_now">"Nu synchroniseren"</string>
- <string name="sync_menu_sync_cancel">"Synchronisatie annuleren"</string>
- <string name="sync_one_time_sync">"Selecteren om nu te synchroniseren<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"Agenda"</string>
- <string name="sync_contacts">"Contactpersonen"</string>
- <string name="sync_too_many_deletes_desc">"Er zijn <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g> verwijderde items voor <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>, account <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>. Wat wilt u doen?"</string>
- <string name="sync_really_delete">"De items verwijderen."</string>
- <string name="sync_undo_deletes">"Verwijderingen ongedaan maken."</string>
- <string name="sync_do_nothing">"Nu niets doen."</string>
- <string name="sync_is_failing">"Er zijn momenteel problemen met de synchronisatie. Synchronisatie wordt snel opnieuw uitgevoerd."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Welkom bij Google Sync!"</font>" "\n"Een benadering van Google voor de synchronisatie van gegevens, zodat u altijd en overal toegang heeft tot uw contactpersonen, afspraken en nog veel meer."</string>
- <string name="header_application_sync_settings">"Synchronatie-instellingen van de toepassing"</string>
- <string name="header_general_sync_settings">"Algemene instellingen voor synchronisatie"</string>
-</resources>
diff --git a/res/values-pl/strings.xml b/res/values-pl/strings.xml
deleted file mode 100644
index b930aef..0000000
--- a/res/values-pl/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"Synchronizacja danych"</string>
- <string name="sync_too_many_deletes">"Przekroczono limit usuwania"</string>
- <string name="background_data">"Dane w tle"</string>
- <string name="background_data_summary">"Włącz używanie danych w tle"</string>
- <string name="background_data_dialog_title">"Uwaga"</string>
- <string name="background_data_dialog_message">"Wyłączenie danych w tle umożliwia oszczędzanie baterii i zmniejsza wykorzystanie danych. Mimo to niektóre aplikacje mogą nadal korzystać z połączenia transmisji danych w tle."</string>
- <string name="sync_automatically">"Automatyczna synchronizacja"</string>
- <string name="sync_automatically_summary">"Automatycznie synchronizuj dane"</string>
- <string name="sync_menu_sync_now">"Synchronizuj teraz"</string>
- <string name="sync_menu_sync_cancel">"Anuluj synchronizację"</string>
- <string name="sync_one_time_sync">"Wybierz elementy do zsynchronizowania teraz<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"Kalendarz"</string>
- <string name="sync_contacts">"Kontakty"</string>
- <string name="sync_too_many_deletes_desc">"Liczba usuniętych elementów: <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g> dla <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g> na koncie <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>. Co chcesz zrobić?"</string>
- <string name="sync_really_delete">"Usuń elementy."</string>
- <string name="sync_undo_deletes">"Cofnij usunięcie."</string>
- <string name="sync_do_nothing">"Nie wykonuj teraz żadnych czynności."</string>
- <string name="sync_is_failing">"Podczas synchronizacji wystąpiły problemy. Synchronizacja zostanie wkrótce wznowiona."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Witamy w Google Sync!"</font>" "\n"Firma Google umożliwia synchronizację danych i dostęp do kontaktów, terminów oraz innych informacji z dowolnego miejsca."</string>
- <string name="header_application_sync_settings">"Ustawienia synchronizacji aplikacji"</string>
- <string name="header_general_sync_settings">"Ogólne ustawienia synchronizacji"</string>
-</resources>
diff --git a/res/values-ru/strings.xml b/res/values-ru/strings.xml
deleted file mode 100644
index 18e44ed..0000000
--- a/res/values-ru/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"Синхронизация данных"</string>
- <string name="sync_too_many_deletes">"Превышен предел удаления"</string>
- <string name="background_data">"Фоновые данные"</string>
- <string name="background_data_summary">"Включить фоновое использование данных"</string>
- <string name="background_data_dialog_title">"Внимание"</string>
- <string name="background_data_dialog_message">"Отключение фоновых данных экономит энергию батареи и уменьшает использование данных. Некоторые приложения могут, тем не менее, использовать фоновую передачу данных."</string>
- <string name="sync_automatically">"Автосинхронизация"</string>
- <string name="sync_automatically_summary">"Автоматическая синхронизация данных"</string>
- <string name="sync_menu_sync_now">"Синхронизировать сейчас"</string>
- <string name="sync_menu_sync_cancel">"Отменить синхронизацию"</string>
- <string name="sync_one_time_sync">"Выберите для синхронизации прямо сейчас<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"Календарь"</string>
- <string name="sync_contacts">"Контакты"</string>
- <string name="sync_too_many_deletes_desc">"Удаленных объектов для <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>: <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g>, аккаунт <xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>. Что нужно сделать?"</string>
- <string name="sync_really_delete">"Удалить элементы."</string>
- <string name="sync_undo_deletes">"Отменить удаления."</string>
- <string name="sync_do_nothing">"Ничего не делать сейчас."</string>
- <string name="sync_is_failing">"Проблемы с синхронизацией. Скоро все снова будет работать."</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"Добро пожаловать в Google Sync!"</font>" "\n"Подход Google к синхронизации данных, позволяющий получить данные о контактах, встречах и многом другом, где бы вы ни были."</string>
- <string name="header_application_sync_settings">"Настройки синхронизации приложения"</string>
- <string name="header_general_sync_settings">"Общие настройки синхронизации"</string>
-</resources>
diff --git a/res/values-zh-rCN/strings.xml b/res/values-zh-rCN/strings.xml
deleted file mode 100644
index 9410d3a..0000000
--- a/res/values-zh-rCN/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"数据同步"</string>
- <string name="sync_too_many_deletes">"超出删除限制"</string>
- <string name="background_data">"背景数据"</string>
- <string name="background_data_summary">"启用背景数据使用"</string>
- <string name="background_data_dialog_title">"注意事项"</string>
- <string name="background_data_dialog_message">"禁用背景数据可节省电池并可降低数据使用率。有些应用程序可能仍会使用背景数据连接。"</string>
- <string name="sync_automatically">"自动同步"</string>
- <string name="sync_automatically_summary">"自动同步数据"</string>
- <string name="sync_menu_sync_now">"立即同步"</string>
- <string name="sync_menu_sync_cancel">"取消同步"</string>
- <string name="sync_one_time_sync">"选择立即同步<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"日历"</string>
- <string name="sync_contacts">"联系人"</string>
- <string name="sync_too_many_deletes_desc">"帐户<xliff:g id="ACCOUNT_NAME">%3$s</xliff:g>有 <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g> 个关于<xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g>的删除项。您要如何操作?"</string>
- <string name="sync_really_delete">"删除这些项。"</string>
- <string name="sync_undo_deletes">"撤消删除。"</string>
- <string name="sync_do_nothing">"目前不进行任何操作。"</string>
- <string name="sync_is_failing">"同步现在遇到问题。很快将返回此操作。"</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"欢迎使用 Google Sync!"</font>\n"Google 同步数据的方法可以让您从任何地方访问您的联系人、约会以及更多信息。"</string>
- <string name="header_application_sync_settings">"应用程序同步设置"</string>
- <string name="header_general_sync_settings">"常规同步设置"</string>
-</resources>
diff --git a/res/values-zh-rTW/strings.xml b/res/values-zh-rTW/strings.xml
deleted file mode 100644
index c44fffd..0000000
--- a/res/values-zh-rTW/strings.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Copyright (C) 2009 The Android Open Source Project
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
--->
-<resources xmlns:android="http://schemas.android.com/apk/res/android"
- xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
- <string name="sync_settings">"資料同步"</string>
- <string name="sync_too_many_deletes">"達到刪除上限"</string>
- <string name="background_data">"背景資料"</string>
- <string name="background_data_summary">"啟用背景資料"</string>
- <string name="background_data_dialog_title">"注意"</string>
- <string name="background_data_dialog_message">"停用背景資料可節省電力並減少使用資料。但某些應用程式可能仍會使用背景資料連線。"</string>
- <string name="sync_automatically">"自動同步"</string>
- <string name="sync_automatically_summary">"自動同步資料"</string>
- <string name="sync_menu_sync_now">"立即同步"</string>
- <string name="sync_menu_sync_cancel">"取消同步"</string>
- <string name="sync_one_time_sync">"選取此處立即開始同步<xliff:g id="LAST_SYNC_TIME">
-%1$s</xliff:g>"</string>
- <string name="sync_gmail">"Gmail"</string>
- <string name="sync_calendar">"日曆"</string>
- <string name="sync_contacts">"通訊錄"</string>
- <string name="sync_too_many_deletes_desc">"<xliff:g id="ACCOUNT_NAME">%3$s</xliff:g> 帳戶的 <xliff:g id="TYPE_OF_SYNC">%2$s</xliff:g> 同步有 <xliff:g id="NUMBER_OF_DELETED_ITEMS">%1$d</xliff:g> 個刪除的項目。您想要怎麼做?"</string>
- <string name="sync_really_delete">"刪除這些項目。"</string>
- <string name="sync_undo_deletes">"復原刪除。"</string>
- <string name="sync_do_nothing">"暫時不要執行任何動作"</string>
- <string name="sync_is_failing">"同步目前發生問題。將於短時間內恢復。"</string>
- <string name="sync_plug"><font fgcolor="#ffffffff">"歡迎使用 Google Sync!"</font>\n"這是 Google 提供用來同步資料的方法,可以讓您隨時隨地存取通訊錄、約會等資料。"</string>
- <string name="header_application_sync_settings">"應用程式同步設定"</string>
- <string name="header_general_sync_settings">"一般同步設定"</string>
-</resources>
diff --git a/src/com/android/providers/subscribedfeeds/SubscribedFeedsSyncAdapter.java b/src/com/android/providers/subscribedfeeds/SubscribedFeedsSyncAdapter.java
index 6094ed3..06a75ce 100644
--- a/src/com/android/providers/subscribedfeeds/SubscribedFeedsSyncAdapter.java
+++ b/src/com/android/providers/subscribedfeeds/SubscribedFeedsSyncAdapter.java
@@ -60,7 +60,7 @@ public class SubscribedFeedsSyncAdapter extends AbstractGDataSyncAdapter {
super(context, provider);
mSubscribedFeedsClient =
new SubscribedFeedsClient(
- new AndroidGDataClient(context),
+ new AndroidGDataClient(context.getContentResolver()),
new XmlSubscribedFeedsGDataParserFactory(
new AndroidXmlParserFactory()));
}