summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Chabot <brettchabot@android.com>2009-06-17 09:51:54 -0700
committerBrett Chabot <brettchabot@android.com>2009-06-17 09:51:54 -0700
commit51823c086b4af424aa0882315fe20deedc897a4e (patch)
treed7a498b23e8408247e3d6011af043fefa0d93210
parente9288557fafb8594c70ac6de0f362c08a8b3fe10 (diff)
downloadImProvider-51823c086b4af424aa0882315fe20deedc897a4e.tar.gz
Add permission test for im provider.
-rw-r--r--Android.mk3
-rw-r--r--tests/Android.mk10
-rw-r--r--tests/permission/Android.mk14
-rw-r--r--tests/permission/AndroidManifest.xml39
-rw-r--r--tests/permission/src/com/android/providers/im/permission/tests/ImProviderPermissionsTest.java53
5 files changed, 119 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 4c2023a..cc4b7f0 100644
--- a/Android.mk
+++ b/Android.mk
@@ -14,3 +14,6 @@ LOCAL_PACKAGE_NAME := ImProvider
LOCAL_CERTIFICATE := shared
include $(BUILD_PACKAGE)
+
+# additionally, build sub-tests in a separate .apk
+include $(call all-makefiles-under,$(LOCAL_PATH)) \ No newline at end of file
diff --git a/tests/Android.mk b/tests/Android.mk
new file mode 100644
index 0000000..e9e3a87
--- /dev/null
+++ b/tests/Android.mk
@@ -0,0 +1,10 @@
+LOCAL_PATH:= $(call my-dir)
+
+########################
+
+include $(CLEAR_VARS)
+
+# no tests to build for now
+
+# additionally, build sub-tests in a separate .apk
+include $(call all-makefiles-under,$(LOCAL_PATH)) \ No newline at end of file
diff --git a/tests/permission/Android.mk b/tests/permission/Android.mk
new file mode 100644
index 0000000..554ad62
--- /dev/null
+++ b/tests/permission/Android.mk
@@ -0,0 +1,14 @@
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+# We only want this apk build for tests.
+LOCAL_MODULE_TAGS := tests
+
+# Include all test java files.
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+
+LOCAL_JAVA_LIBRARIES := android.test.runner
+LOCAL_PACKAGE_NAME := ImProviderPermissionTests
+
+include $(BUILD_PACKAGE)
+
diff --git a/tests/permission/AndroidManifest.xml b/tests/permission/AndroidManifest.xml
new file mode 100644
index 0000000..fe83af1
--- /dev/null
+++ b/tests/permission/AndroidManifest.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+ * Copyright (C) 2009 Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ -->
+
+<manifest xmlns:android="http://schemas.android.com/apk/res/android"
+ package="com.android.providers.im.permission.tests">
+
+ <application>
+ <uses-library android:name="android.test.runner" />
+ </application>
+
+ <!--
+ The tests in this package are intended to verify that protected APIs or data
+ cannot be accessed without the necessary permissions. Thus this manifest should not
+ include any uses-permissions tags
+ -->
+
+ <!--
+ The test declared in this instrumentation can be run via this command
+ "adb shell am instrument -w com.android.providers.im.permission.tests/android.test.InstrumentationTestRunner"
+ -->
+ <instrumentation android:name="android.test.InstrumentationTestRunner"
+ android:targetPackage="com.android.providers.im.permission.tests"
+ android:label="Tests for IM provider permissions"/>
+
+</manifest>
diff --git a/tests/permission/src/com/android/providers/im/permission/tests/ImProviderPermissionsTest.java b/tests/permission/src/com/android/providers/im/permission/tests/ImProviderPermissionsTest.java
new file mode 100644
index 0000000..0f2f0ae
--- /dev/null
+++ b/tests/permission/src/com/android/providers/im/permission/tests/ImProviderPermissionsTest.java
@@ -0,0 +1,53 @@
+/*
+ * Copyright (C) 2009 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.providers.im.permission.tests;
+
+import java.io.IOException;
+
+import android.net.Uri;
+import android.test.AndroidTestCase;
+import android.test.suitebuilder.annotation.MediumTest;
+
+/**
+ * Verify that protected Im provider actions require specific permissions.
+ */
+public class ImProviderPermissionsTest extends AndroidTestCase {
+
+ private static final String CONTENT_IM = "content://im";
+
+ /**
+ * Test that an untrusted app cannot read from the im provider
+ * <p>Tests Permission:
+ * {@link com.android.providers.im.Manifest.permission#READ_ONLY}
+ */
+ @MediumTest
+ public void testReadImProvider() throws Exception {
+ assertReadingContentUriRequiresPermission(Uri.parse(CONTENT_IM),
+ "com.android.providers.im.permission.READ_ONLY");
+ }
+
+ /**
+ * Test that an untrusted app cannot write to the download provider
+ * <p>Tests Permission:
+ * {@link com.android.providers.downloads.Manifest.permission#ACCESS_DOWNLOAD_MANAGER}
+ */
+ @MediumTest
+ public void testWriteImProvider() throws IOException {
+ assertWritingContentUriRequiresPermission(Uri.parse(CONTENT_IM),
+ "com.android.providers.im.permission.WRITE_ONLY");
+ }
+}