summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWei Huang <weih@google.com>2009-08-26 16:28:06 -0700
committerWei Huang <weih@google.com>2009-08-26 22:21:31 -0700
commit6c4e21562ec2c92e4a54d1665ba9fc27ba14aeaa (patch)
tree130933a1547c264879f0ff378af26d0599ba9511
parent4b58511592ea9c6d20a522246bbe00f8bee13877 (diff)
downloadImProvider-6c4e21562ec2c92e4a54d1665ba9fc27ba14aeaa.tar.gz
run IM provider in gapps process instead of acore, so everything GTalkService needs to run as a persistent serviceandroid-sdk-tools_r2android-sdk-1.6_r1android-sdk-1.6-docs_r1android-1.6_r1.5android-1.6_r1.4android-1.6_r1.3android-1.6_r1.2android-1.6_r1.1android-1.6_r1donut-release2
lives inside a single process. This hopefully relieves some memory pressure in Donut. The negative side effect of this is when the user upgrade to Donut, he will lose his old IM storage, which in Donut contains any account username/pw for AIM/Yahoo/MSN, the provider settings (i.e. auto-login, notification ringtones, etc), and the outgoing RMQ messages not yet received by MCS. The amount of data lost is not significant and can all be recovered by the user. It's not he will lost chat messages because we don't store those in persistent storage in Donut. The things done to make IM provider running in gapps are: - make IM provider use the google uid. - make it run in the process "com.google.process.gapps" - in the make file, make it use "vendor/google/certs/app" certificate.
-rw-r--r--Android.mk2
-rw-r--r--AndroidManifest.xml4
2 files changed, 3 insertions, 3 deletions
diff --git a/Android.mk b/Android.mk
index f7f22cc..977074e 100644
--- a/Android.mk
+++ b/Android.mk
@@ -11,7 +11,7 @@ LOCAL_JAVA_LIBRARIES := ext \
# classes defined in this plugin package)
LOCAL_PACKAGE_NAME := ImProvider
-LOCAL_CERTIFICATE := shared
+LOCAL_CERTIFICATE := vendor/google/certs/app
include $(BUILD_PACKAGE)
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
index 8609528..5d39ed1 100644
--- a/AndroidManifest.xml
+++ b/AndroidManifest.xml
@@ -1,6 +1,6 @@
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="com.android.providers.im"
- android:sharedUserId="android.uid.shared">
+ android:sharedUserId="com.google.uid.shared">
<permission android:name="com.android.providers.im.permission.READ_ONLY"
android:permissionGroup="android.permission-group.MESSAGES"
@@ -17,7 +17,7 @@
<uses-permission android:name="com.android.providers.im.permission.READ_ONLY" />
<uses-permission android:name="com.android.providers.im.permission.WRITE_ONLY" />
- <application android:process="android.process.acore"
+ <application android:process="com.google.process.gapps"
android:label="@string/im_label"
android:icon="@drawable/ic_launcher_im"
android:taskAffinity="android.task.im">