summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Chabot <brettchabot@google.com>2009-07-16 13:36:22 -0700
committerBrett Chabot <brettchabot@google.com>2009-07-16 13:36:22 -0700
commit9d6f85f0aa19d210cec631b55428ee3b2b9b1036 (patch)
tree9bd6b89eb3907038ac589182fea221f4559c2075
parentf0cd2abf0fac2e6cbf19428402bc26609e1152db (diff)
downloadImProvider-9d6f85f0aa19d210cec631b55428ee3b2b9b1036.tar.gz
Fix ImProvider makefile so tests source are not included when building Improvider package.
-rw-r--r--Android.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Android.mk b/Android.mk
index cc4b7f0..f7f22cc 100644
--- a/Android.mk
+++ b/Android.mk
@@ -3,7 +3,7 @@ include $(CLEAR_VARS)
LOCAL_MODULE_TAGS := user
-LOCAL_SRC_FILES := $(call all-subdir-java-files)
+LOCAL_SRC_FILES := $(call all-java-files-under,src)
LOCAL_JAVA_LIBRARIES := ext \
com.android.im.plugin # TODO: remove this and load this on demand.
@@ -16,4 +16,4 @@ LOCAL_CERTIFICATE := shared
include $(BUILD_PACKAGE)
# additionally, build sub-tests in a separate .apk
-include $(call all-makefiles-under,$(LOCAL_PATH)) \ No newline at end of file
+include $(call all-makefiles-under,$(LOCAL_PATH))