summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 18:31:39 +0000
committerAnton Hansson <hansson@google.com>2018-02-23 11:48:09 +0000
commitbaa20d2143ee68c69e3c00347f2ca9a89cc1d529 (patch)
treeae84ddc9e51649f1021fb64e671c73db32b5fc19
parentfd2b16a0ebcee4b0810c8051b2cd22cfa99f8ba0 (diff)
downloadPartnerBookmarksProvider-baa20d2143ee68c69e3c00347f2ca9a89cc1d529.tar.gz
packages/providers/PartnerBookmarksProvider: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Merged-In: I7ba748f11eb087357c31185ed256323696e6468b Change-Id: I2886c30803dae56ba45512bf223bf74a5e27c345
-rw-r--r--Android.mk1
-rw-r--r--tests/Android.mk3
2 files changed, 3 insertions, 1 deletions
diff --git a/Android.mk b/Android.mk
index 6978cfa..100cfcb 100644
--- a/Android.mk
+++ b/Android.mk
@@ -23,6 +23,7 @@ LOCAL_STATIC_JAVA_LIBRARIES := android-common
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := PartnerBookmarksProvider
+LOCAL_SDK_VERSION := current
include $(BUILD_PACKAGE)
diff --git a/tests/Android.mk b/tests/Android.mk
index b509e96..8a107c7 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -23,8 +23,9 @@ LOCAL_MODULE_TAGS := tests
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := PartnerBookmarksProviderTest
+LOCAL_SDK_VERSION := current
-LOCAL_JAVA_LIBRARIES := ext legacy-android-test
+LOCAL_JAVA_LIBRARIES := android.test.base.stubs
LOCAL_STATIC_JAVA_LIBRARIES := junit
LOCAL_INSTRUMENTATION_FOR := PartnerBookmarksProvider