summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-09 10:02:08 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-09 10:02:08 -0800
commite9213fdd0563e64ded7b17757c6187741b70260c (patch)
tree5d42479cb4954878ee8a9e52d1a2a1ef92d63f36
parentf74c6164152b2294b887e3c96e57af9da4b01aca (diff)
parent4a5064b3876e3ba485fb5f9e024c4508b162a99d (diff)
downloadPartnerBookmarksProvider-e9213fdd0563e64ded7b17757c6187741b70260c.tar.gz
Merge "Convert Android.mk file to Android.bp."
am: 4a5064b387 Change-Id: I0ebc67a904b9e6a3f1d65ffa639427f67166e660
-rw-r--r--Android.bp25
-rw-r--r--Android.mk32
-rw-r--r--tests/Android.bp25
-rw-r--r--tests/Android.mk33
4 files changed, 50 insertions, 65 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..dc45966
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,25 @@
+//
+// Copyright (C) 2012 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+android_app {
+ name: "PartnerBookmarksProvider",
+ static_libs: ["android-common"],
+ srcs: ["src/**/*.java"],
+ sdk_version: "current",
+ optimize: {
+ proguard_flags_files: ["proguard.flags"],
+ },
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index b85a651..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,32 +0,0 @@
-#
-# Copyright (C) 2012 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_STATIC_JAVA_LIBRARIES := android-common
-
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := PartnerBookmarksProvider
-LOCAL_SDK_VERSION := current
-LOCAL_PROGUARD_FLAG_FILES := proguard.flags
-
-include $(BUILD_PACKAGE)
-
-# additionally, build tests in sub-folders in a separate .apk
-include $(call all-makefiles-under,$(LOCAL_PATH))
diff --git a/tests/Android.bp b/tests/Android.bp
new file mode 100644
index 0000000..6f1eac2
--- /dev/null
+++ b/tests/Android.bp
@@ -0,0 +1,25 @@
+//
+// Copyright (C) 2012 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+android_test {
+ name: "PartnerBookmarksProviderTest",
+ // Include all test java files.
+ srcs: ["src/**/*.java"],
+ sdk_version: "current",
+ libs: ["android.test.base.stubs"],
+ static_libs: ["junit"],
+ instrumentation_for: "PartnerBookmarksProvider",
+}
diff --git a/tests/Android.mk b/tests/Android.mk
deleted file mode 100644
index 8a107c7..0000000
--- a/tests/Android.mk
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (C) 2012 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-# We only want this apk build for tests.
-LOCAL_MODULE_TAGS := tests
-
-# Include all test java files.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := PartnerBookmarksProviderTest
-LOCAL_SDK_VERSION := current
-
-LOCAL_JAVA_LIBRARIES := android.test.base.stubs
-LOCAL_STATIC_JAVA_LIBRARIES := junit
-
-LOCAL_INSTRUMENTATION_FOR := PartnerBookmarksProvider
-
-include $(BUILD_PACKAGE)