summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-09 10:02:06 -0800
committerSasha Smundak <asmundak@google.com>2019-01-09 10:02:06 -0800
commit99746fd1cddf03de979a786c569992f619179e01 (patch)
tree66b1e4771c72c67e633ca0910e9f6ffcf24be262
parentadf97342507b5495ad8bda4bc5a614ee093fbcff (diff)
downloadWebView-99746fd1cddf03de979a786c569992f619179e01.tar.gz
Convert Android.mk file to Android.bp
See build/soong/README.md for more information. Change-Id: I52d90849d5d83478b1d574cb8ecac28b09da121c Fixes: 122332717 Test: treehugger
-rw-r--r--Android.bp6
-rw-r--r--Android.mk18
2 files changed, 6 insertions, 18 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..1460abd
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,6 @@
+android_app {
+ name: "WebViewDream",
+ // Only compile source java files in this apk.
+ srcs: ["src/**/*.java"],
+ sdk_version: "current",
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index 7f79bc3..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-# Only compile source java files in this apk.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := WebViewDream
-LOCAL_SDK_VERSION := current
-
-# need tasty bits
-# LOCAL_CERTIFICATE := platform
-
-include $(BUILD_PACKAGE)
-
-# Use the following include to make our test apk.
-include $(call all-makefiles-under,$(LOCAL_PATH))