summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Ferris <bferris@google.com>2019-07-01 15:08:59 -0700
committerHuizi Yang <yanghuiz@google.com>2019-10-08 14:05:34 -0700
commit0dc443ac3475351b7f3ae0ad5ceb55fe8917b2c0 (patch)
tree2c0f659da106542001a049881c5e4c9e4d45c388
parent5ff6360204c3ab4f9637c35dd33cef7104390417 (diff)
downloadBuiltInPrintService-oreo-security-release.tar.gz
In order to address the security vulnerability at b/111210196 we are upgrading the libcups library. There are some calls to functions that are deprecated between the versions; in order to minimize churn in legacy branches we are allowing deprecated functions to be called rather than modifying the code to use the new functions. Bug: 111210196 Test: adb shell am instrument -w android.print.cts/android.support.test.runner.AndroidJUnitRunner Change-Id: I2b7d568c9f8878d27d9e53f96930d62d07b7d84a (cherry picked from commit 5fb3126bb50ba958b473f09201bf70eee8659ada)
-rw-r--r--jni/Android.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/jni/Android.mk b/jni/Android.mk
index d57c115..5dbe400 100644
--- a/jni/Android.mk
+++ b/jni/Android.mk
@@ -26,7 +26,9 @@ LOCAL_SDK_VERSION := current
LOCAL_CFLAGS += \
-DINCLUDE_PDF=1 -Werror -Wextra -Wno-unused-parameter \
-Wno-sign-compare -Wno-missing-field-initializers \
- -Wno-implicit-function-declaration -Wno-format -Wno-missing-braces
+ -Wno-implicit-function-declaration -Wno-format -Wno-missing-braces \
+ -Wno-deprecated-declarations
+
PLUGINS_SRCS := \
$(PLUGINS_DIR)/lib_pclm.c $(PLUGINS_DIR)/lib_pwg.c \