aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Eyler <bryaneyler@google.com>2017-06-21 17:18:12 -0700
committerBryan Eyler <bryaneyler@google.com>2017-06-21 17:18:12 -0700
commit4bd1d572a9001fe92a6a145e7d1d0439ff20c10f (patch)
tree17a6c804daa511dce0e7c50bd3db3c28b32753f9
parenta0a0d823c691a4e8f11d475a1913373880aa9542 (diff)
downloadCar-4bd1d572a9001fe92a6a145e7d1d0439ff20c10f.tar.gz
Disable Car apps in PDK until the dependencies are fixed.
Bug 62360631 Change-Id: I12e29914940c91fe27d623f2ec91770f47231c1e
-rw-r--r--TrustAgent/Android.mk3
-rw-r--r--car-maps-placeholder/Android.mk4
-rw-r--r--car-usb-handler/Android.mk4
3 files changed, 11 insertions, 0 deletions
diff --git a/TrustAgent/Android.mk b/TrustAgent/Android.mk
index dc70ef30f2..a57308a163 100644
--- a/TrustAgent/Android.mk
+++ b/TrustAgent/Android.mk
@@ -13,6 +13,8 @@
# limitations under the License.
#
+ifneq ($(TARGET_BUILD_PDK), true)
+
LOCAL_PATH:= $(call my-dir)
include $(CLEAR_VARS)
@@ -37,3 +39,4 @@ LOCAL_STATIC_JAVA_LIBRARIES := android-support-v4
include $(BUILD_PACKAGE)
+endif
diff --git a/car-maps-placeholder/Android.mk b/car-maps-placeholder/Android.mk
index 5f0b93ad73..53cdbf8bb3 100644
--- a/car-maps-placeholder/Android.mk
+++ b/car-maps-placeholder/Android.mk
@@ -14,6 +14,8 @@
# limitations under the License.
#
+ifneq ($(TARGET_BUILD_PDK), true)
+
LOCAL_PATH:= $(call my-dir)
include $(CLEAR_VARS)
@@ -35,3 +37,5 @@ LOCAL_DEX_PREOPT := false
include packages/apps/Car/libs/car-stream-ui-lib/car-stream-ui-lib.mk
include $(BUILD_PACKAGE)
+
+endif
diff --git a/car-usb-handler/Android.mk b/car-usb-handler/Android.mk
index c0508540a5..3194250651 100644
--- a/car-usb-handler/Android.mk
+++ b/car-usb-handler/Android.mk
@@ -14,6 +14,8 @@
#
#
+ifneq ($(TARGET_BUILD_PDK), true)
+
LOCAL_PATH:= $(call my-dir)
include $(CLEAR_VARS)
@@ -33,3 +35,5 @@ LOCAL_PROGUARD_ENABLED := disabled
LOCAL_JAVA_LIBRARIES += android.car
include $(BUILD_PACKAGE)
+
+endif