aboutsummaryrefslogtreecommitdiff
path: root/gd/rust/facade_proto/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'gd/rust/facade_proto/Cargo.toml')
-rw-r--r--gd/rust/facade_proto/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/gd/rust/facade_proto/Cargo.toml b/gd/rust/facade_proto/Cargo.toml
new file mode 100644
index 000000000..c69c86981
--- /dev/null
+++ b/gd/rust/facade_proto/Cargo.toml
@@ -0,0 +1,34 @@
+#
+# Copyright 2021 Google, Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+[package]
+name = "bt_facade_proto"
+version = "0.0.1"
+edition = "2018"
+build = "build.rs"
+
+[dependencies]
+bt_hci_custom_types = { path = "../hci/custom_types" }
+futures = "*"
+grpcio = "*"
+protobuf = "*"
+
+[build-dependencies]
+protoc-rust = "*"
+protoc-grpcio = "*"
+protobuf-codegen = "*"
+
+[lib]
+crate-types = ["rlib"]