aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 30 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 00249c9..b316a7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -525,7 +525,7 @@ AC_MSG_RESULT($GDB_VERSION)
AC_SUBST(GDB_VERSION)
ANDROID_CHECK_PACKAGE(gdb-${GDB_VERSION})
-# Figure out what version of gdb we're building.
+# figure out if we need to build expat for gdb 7.2+
gdb_version_file="${srcdir}/../gdb/gdb-${GDB_VERSION}/gdb/version.in"
if test -f "${gdb_version_file}"; then
GDB_MAJOR=`head -n 1 $gdb_version_file | sed -e "s/[[^0-9]].*//"`
@@ -544,6 +544,22 @@ fi
AC_SUBST(GDB_MIN_VERSION_7_2)
if test "$GDB_MIN_VERSION_7_2" == "yes"; then
+# expat version (default is 2.0.1)
+# expat is only used for gdb version higher than 7.2
+AC_MSG_CHECKING([expat version])
+AC_ARG_WITH([expat-version],
+ [ --with-expat-version=VERSION
+ use expat-VERSION (default is 2.0.1)],
+ [if test x"$withval" != x ; then
+ EXPAT_VERSION="$withval"
+ fi],
+[EXPAT_VERSION="2.0.1"])
+AC_MSG_RESULT($EXPAT_VERSION)
+ANDROID_CHECK_PACKAGE(expat-${EXPAT_VERSION})
+fi
+AC_SUBST(EXPAT_VERSION)
+
+if test "$GDB_MIN_VERSION_7_2" == "yes"; then
AC_MSG_CHECKING([with python])
AC_ARG_WITH([python],
[ --with-python=WITH_PYTHON
@@ -671,4 +687,17 @@ AC_ARG_WITH(isl, [ --with-isl=PATH
[have_isl=no])
AC_SUBST(have_isl)
+# Specify a location for expat
+AC_ARG_WITH(expat, [ --with-expat=PATH
+ specify prefix directory for the installed EXPAT package.],
+ [if test -d "$withval" ; then
+ have_expat="$withval"
+ elif test x"$withval" != x"no"; then
+ AC_MSG_ERROR(invalid value for --with-expat)
+ else
+ have_expat=no
+ fi],
+ [have_expat=no])
+AC_SUBST(have_expat)
+
AC_OUTPUT